Download of 3d warehouse not working

I’m trying to import models from 3d warehouse in sketchup make 2017 but whenever I click on download nothing seems to be happening. What should I do?

Not supported anymore, search the topic for more details.

As Guido wrote. the 3D Warehouse doesn’t support SketchUp 2017 Make. See:

https://help.sketchup.com/en/current-minus-two-version-policy

along with numerous threads on the topic in the 3D Warehouse forum category.

Your profile says you are using SketchUp Free (web). That version is supported be the 3D Warehouse. If you aren’t really using that version, please correct your profile.

I see.

There’s no collada file option for me. Tried right clicking on the download button and everything.

What exactly are you trying to download?

Here’s a table and chairs picked at random.
collada

Use your Internet browser, not the window inside SketchUp.

Thanks Dave

1 Like

Oh so that was the cause of it. Can see the dropdown list from the download button now, thanks.

That was explained in the link I provided in my first reply to you.


I tried downloading escalator models as collada files but they all show up as .zip rather than .dae

A collada file is a zip file that includes the .dae and a folder of materials. You have to extract the contents of the zip file. Then when you import the .dae file the importer will look for the folder to import the materials.

I see, can import the models now. Thanks.

1 Like