Dimensioning tool in Sketchup Make

Can anyone tell me if the dimensioning tool is supposed to work in Sketchup Make? I have used successfully, but most of the time when I select the tool I just get a standard pointer and I don’t seem to have any way of selecting endpoints to create dimensions from. I’m now starting to wonder if it was working when I was using the trial version of Pro, but possibly stopped working when that expired and I went back to Make?

Yes it works with make.

I thought it did – I was sure I had used it after my version switched back to Make. I must have some intermittent problem in the software or my configuration. Do you know if there’s anything special I need to do to get it to work?

Nothing special, it should just work.
Perhaps you didn’t install SU correctly to begin with.
Sketchup needs to be installed by Right clicking on the Install file and choosing Run as Admin.
If you installed by double click you can run into some strange anomalies.

Go and find the original install.exe, probably in your download folder, right click and Runs as Admin, then choose repair when you get the option.

Does the cursor changes when selecting the tool?
You might have hit the label tool?

No, nothing happens. I’m definitely heading the Dimension tool. This has happened to me before some time ago, then the last time I tried it worked fine (exactly as you demonstrate), but now it’s not working again.

BTW – how do you guys make these terrific demo videos so quickly?

Just thinking, do I have to open groups to measure individual dimensions of objects within a group?

Just tried that – doesn’t seem to work.

Just tried reinstalling Sketchup as Administrator – no joy there, either.

Gif: Sometimes Snaggit, most times Licecap.

Like @Box said this looks like incorrect installation. do you also have the latest (maintenance) update of your version of SketchUp running? Your profile indicates that you ar not.
Go to the download section of Sketchup and download your version. Then, go to the download folder and right click on the installation file ( If packed, unzip first :slight_smile: ) when prompted, choose repair.

I downloaded a new version a week or so ago, and I think it’s the most recent one. I’ll download it again, though. This is the version I am currently using:


I have just started a graphics course at my nearest Community College and have ordered Sketchup Pro. Hopefully that will fix it!

Maybe, your Microsoft Visual C++ libraries are corrupt, you could try uninstalling them prior to reinstall SketchUp. Go to Programs and search for Microsoft Visual C++ 2015 Redistributable. Remove those files (only 2015) and let SketchUp install them.

I have narrowed it down to a problem with the model itself. I tried adding a simple box in a new model, and the tool works fine. I will try cutting and pasting all the elements of my existing model into a new file and see if that works.

That’s good to hear.! Does your model have imported items that ,by chance, have ‘way off’ origins?

It could certainly have something to do with that – I have downloaded a number of models of various things (furniture, vegetation, etc). Is there some way I could easily find out if any of the imported items have a problem with the origin?

If your model has a very large number of edges, and/or your file size including unused components has grown very large, SU can slow down so much you think it isn’t working. Importing vegetation is one way to overload SU very quickly! And much of the furniture on the 3dwarehouse is also GROSSLY over detailed.

If you aren’t using some or a lot of the imported stuff, try purging the original model (Window/Model info/Statistics/Purge unused) and try the Dimension tool again.

Also use ‘Zoom Extents’ to see what happens and to verify that the modeling space in use isn’t extreme.
If so, it’s time to search for entities far from the systems origin.

Hi folks. I have now upgraded to Sketchup Pro but the same problem still exists. I’ve tried everything that has been suggested, but no success. If someone felt motivated to take a look at the model to see if there’s anything obvious I have done or missed, I’d be most grateful. BTW – this is (or rather, will be) my wife and my new home in beautiful Port Stephens, just north of Newcastle, Australia.

Link to model: https://1drv.ms/u/s!Aoji0JeMZSPYgYQx8-AqUgR6tIx33Q


You have deselected the edges in the styles menu!