Difficulties creating multipart STL (printable) file from Sketchup 2021 Export

I am having several troubles exporting STL files for printing.

The main problem is that when I import the two parts into PrusaSlicer, the Z-offset is incorrect for one of the parts. Thus, they do not align where they are supposed to. (Instead of the top sitting immediately on top of the bottom, it sits in the middle.) It seems that the “Z” offset of the top part is wrong.

Each part is in its own group (so they they don’t merge into each other.) Each group is on its own layer (tag) so that they can be individually displayed.

For exporting I select one group, then “Select All” so that everything in that group is selected, and then I export with the “Export only current selection” option when exporting to an STL file. Then, I do the same with the other group.

In the past, I could then go to PrusaSlicer and import one of the STL files, and then “Add Part” to add the second file. (Or add both files and be prompted so that they would be both added as parts of the same Object.) And, in the past, each part would be in the proper position relative to the other parts.

But now the “Z” offset of one of the parts isn’t correct, so instead of being where it belongs, it is in the middle of the other part.

I would welcome any suggestions as to what I may be doing wrong, or what the work-around might be.

Here is how the parts look in Sketchup:

And, here is how they look after being imported into PrusaSlicer: (Notice that the top “sheet” that is yellow in Sketchup is now buried in the middle of the main part in Prusa Slicer (shown in orange), not on top:

Attached are the STL files and the SKP file.

I’m quite miffed as to what is happening. Ive not had this problem in the past, with Sketchup 2020.

Thank you.

2021-01-27 - Test.zip (243.2 KB)

I’d be looking at PrusaSlicer. I exported .stl file from your SketchUp model and uploaded it to i.Materialise and the thin piece is on top of the base as in the SketchUp model.

DaveR:

  1. You can see that it MUST be a SU2021 problem (and not a PrusaSlicer issue) as follows:

    -Start a new project.
    -Import the STL file for the Bottom.
    -Import the STL file for the Top.

You will see that the import exactly reflects the same issue as displayed by Prusa Slicer: The “Top” sits within the middle of the “Bottom”, and not on top of it.

It seems that the “Z” offset/position for the Top part is being exported incorrectly.

The following diagram is a screenshot after following the above steps, with the blue being the “Top” part having been clicked on to hi light. You can see it is positioned in the middle of the Bottom part (shown in black). The (blue) Top part should be on top of (eg sitting above) the (black) Bottom part. Notice that the rendering by Sketchup after the import of the STL files matches the rendering by PrusaSlicer and does not match the original model.

  1. How did you upload both parts together into iMaterialise? I see no option to upload a second STL file for the top. When I tried, it only seemed to allow me to upload a single STL file.

Why do you have to export the model in two parts if it is to be printed in one go? The slicer will merge them all the same. If you need two separate parts you had better produce two separate prints or place the parts side to side.

What I know about 3D printing suggests that your object would print better if placed upside down.

Anssi:

  1. Each part is printed a different color, fused together, to form one plastic piece. The parts are not mechanically fitted, they are printed at the same time to form a single piece of plastic. In this case the Top is printed in clear and the Bottom is printed in an opaque color. The two STL files are each called “parts” and they fit together into a single Object. Each part defines where one color is to be printed.

  2. Of course, the object would be printed upside down from how it is shown. This is a simple thing to do on the Prusa. But it is shown right-side-up for the sake of the user. This is but one piece of a complex Sketchup file that has dozens of layers (tags) that define many aspects of the product, from the placement of printed circuit boards to the mechanical placement of switches and LEDs, the mounting of internal PC Boards, mounting hardware and DIN rails. It makes sense from a design standpoint to design everything from the “normal” perspective. Then, at actual print time you just tell PrusaSlicer to 180 the object and you are correct, then it prints quite nicely.

I see no issues when exported.
Doesn’t fit my home printer bed but it shows no errors.
Print

Did the Top layer properly;y position itself, or did you need to adjust it by 5mm?

The problem is that the STL file appears to be off in the Z axis by 5mm.

I opened your model, exported the stls opened them in my printer software and recorded the gif.