Drawing is turned (not stayed flat) in slicer

Hello there.

I have drawn this object in SKETCHUP ant it looks like this:

When I export this object in STL format, my slicer puts it like this:
image

I have already made a lots of this kind of objects but it’s the first time I get this result.

What am I doing wrong please?

Did you change the drawing axes in SketchUp? You can check by right-clicking on an axis line. If “Reset” is not grayed out, you have changed the axes.

RESET is grayed out - so no changes made there.

Most slicers have a transform panel to allow rotation etc.

1 Like

It should be easy to turn the orientation in your slicer. Include your .skp file here for real diagnosis.

Here it is.

Protection Manometre Electronique 3.skp (288.1 KB)

I made a component of the object, exported the .stl, and opened that in the slicer. Looks like this:


What version of SketchUp are you using? Please complete your forum profile.

I did nothing to your file (except erase the extra hidden geometry you had tagged as Manometer) then exported as .stl. Imported fine to Cura.

Maybe you have the Swap YZ box ticked?

FWIW, I had a quick play and modeled a smoother version of your manometer cover.

2 Likes

I’m using Sketchup Make 2017 - I’ll complete my profile shortly.

I think I don’t have that many options in the STL export menu.

Even as a component, I still have my object not staying as it is in Sketchup…

DaveR, the smooth version looks great!! :star_struck:

Thank you!

No. I don’t think you do. It’s been a long time since I’ve had to use the exporter plugin since the export option became native in 2018. Might look to see if there are any export options available I don’t remember.

Thanks again. When I model for 3D printing I model as if millmeters are meters. So in the case of your manometer cover the dimensions look like this:

That allows for larger numbers of segments in circles, arcs, and other curves. Exporting with Model Units (meters) and importing into the slicer as millimeters everything works fine.

What are you going to print this from? One of those squishy filaments?

Just did something.

I went back, step by step in my drawing.

In fact, my object gets flipped when I use the RoundCorner add.

image

I have a FlashForge Guider IIs printer that comes with its FlashPrint slicer software.

Filament is FiberFlex 40D and it works absolutely fine.

Until now, I never had this problem even when I “rounded” things.

Interesting. Neither Riley nor I had that result with your model when opening it.

I didn’t use anything but native tools when I made my version but I have used Round Corner for a lot of other models and haven’t seen anything like your rotated model. Maybe that’s a difference between 2017 Make and newer versions?

Cool! I haven’t tried any flexible filament in my CR-M4 but want to one of these days.

Maybe it was a one-off thing.

BTW, to update your forum profile click on your avatar at the top right of the forum window. Click on the person icon and then Preferences followed by Profile.

Finally, I got it “straight” without rounding the inside ring of the bottom of my object so it gets really “flat” in the slicer.

It’s fine for me - I honestly don’t need that level of perfection anyway :upside_down_face:

Thanks All for your suggestions and help :wink:

Et voilà!

Thank you for Sktechup Make 2017 FREE :slightly_smiling_face: :+1:

1 Like

I have had it happen once or twice too, but just rotated it in my slicer (Cura) and didn’t think about finding out why it happened…