DC and inches/mms!


#1

New to DCs and looking forward to making use of them. However, I’m having trouble with units - my model is set to metric units (mm) but whenever I enter a attribute value using the Component Options dialogue, it seems to convert the value to inches in the Component Attributes Box, even though the tape measure icon on the Component Attributes box is showing CM (clicking and changing inches doesn’t appear to make any difference?

Here I’m entering 100 into the Hem attribute on the Options window:


After applying the 100, the Hem attribute appears in inches?!?!?

What am I doing wrong? Confused!


#2

I think it’s just that DCs are themselves confusing, and some of the coding seems a bit flaky.

I found much the same.

The thing that helps (but doesn’t solve the issues fully) is to remember that Sketchup’s native unit is the inch, with floating point representation down to about 1/1000th of an inch. All values for lengths, for example, are stored in inches internally, and only converted from other units on input, or output for display in other units.

Wherever units aren’t explicitly specified, SU assumes inches. (And sometimes even when they are, I sometimes think!).

And it still gets extremely confused sometimes.

So if you need to display the value of Hem, you will need to multiply its internal value by 2.54 to get mm where you want it to display in mm, or be used in arithmetic with other dimensions in mm.

It isn’t the same in a DC, but if you are working in any metric unit (mm, cm, metre) and try to enter a value in the measurement box, SU makes a complete pigs ear of a mixture of feet, inches, and fractions. It’s been accepted as a bug.

See this thread. SU doesn't recognise fractional inches (e.g., 1/2") as an imperial measurement when units are mm


#3

Thank you John - that explains it. Am up and running now, but it is a bit of a pigs ear for sure. Surprised that SU works inches in the background!


#4

No need for the conversion in this case. For your attributes that are required to be cm, choose centimeter in the units drop down, don’t rely on grey values, generally the default is text, which SU interprets as inches

you will have to re-enter a correct value in the dialog after the change


#5

That’s much better @pcmoor. Thanks - I’d forgotten that.


#6

but as you said, one still need to convert some of the functions that return inches, this includes current (inches) and facearea (square inches) so your points still valid


#7

The DC code has a known bug (it has been there since they were introduced) where the metric units are recognized only when the “display units format” checkbox is enabled in the Window menu>Model info>Units dialog. Otherwise everything reverts to inches.

Anssi


#8

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.