Curved surfaces intersections

Is there any way to avoid the nearly constant creation of broken or segmented lines when intersecting curved surfaces?
It’s not a matter of scale, as this happens even when far away from the lower “comfortable” limits of SU. It also happens whether the curved surfaces are created via plug-ins such as Curviloft or ordinary extrusion tools. Working with smoothed or un-smoothed surfaces makes no difference.
Over time, I’ve spent countless hours repairing incomplete or damaged lines resulting from these operations.

It’s not clear to me exactly what you are referring to. Could you post an example or two?

Here you go…

intersection example.skp (98.0 KB)

Without the intersecting object who can tell what is up ?

I suspect that you have a relatively small form which intersects resulting in edges < 1/1000" long.
SketchUp’s tolerance assumes that any two points within 1/1000" are coincident and the edge is not made.

If you scale up everything x10 or x100 and do the intersecting, then chances are that complete edges will be formed.
You can then remove the unwanted geometry…

Afterwards you can scale down and the tiny geometry will still exist - tiny edges can’t be created but they can exist !

A common ‘trick’ is to make a component of the small objects, make a copy of it to one side and scale that up, edit the giant copy and do the intersecting etc, when you are happy with the result exit the edit and delete the giant copy.
The small copy will reflect all of the same changes, retaining the tiny edges etc…

3 Likes

As stated in the initial post, I’m aware of the size limits, and have taken them into account. The issue must be elsewhere.

In that case, perhaps you could upload an example .skp file that shows the misbehaviour?

I’ve never experienced what you show. As @TIG wrote, seeing only the aftermath I can’t tell what produced that effect. Maybe something about the way you cleaned up after doing the intersection? Could you provide a “before” model with the entities you intersected still intact?

1 Like

shuttleLG copy.skp (422.3 KB)
I’ve uploaded an unsaved .skp (above), because of what happens when I save it;
before:


after:

As you can see, far from satisfactory. Before saving, there remain some gaps in the intersection lines.
This is 100x the actual size of the object, which I’ll admit is better than the original, actual size upload contained in the original answer I sent to M. Baumgartner.

Perhaps x1000 ?
There are clearly visible missing tiny edges ?
Probably even more !

I’m not clear what steps you are following to create the intersections. In the middle of your file there is an object that has the two profile groups overlapped:


But if I choose view->component edit->hide rest of model and open either of the groups, I see the intersection lines in both of the groups:

Intersect Faces with… always puts new edges into the current edit context (model, open group, or open component). Are you opening the groups one-by-one and then doing Intersect Faces with…Model in each? Or are you copying edges from one group to another? Or something else?

If you turn on hidden geometry and zoom in close, you can see some places where small mismatches between the smoothed edges in the two surfaces’ curves caused intersect to create small zig-zag edges (look closely - the places where the edge rendering changes from profile to regular are shallow corners). But the opposite end of where you would expect a face has only a single edge from the original curve. The resulting outline is not planar so SketchUp can’t create a face. You may need to scale up still larger to avoid this problem.

1 Like

OK thanks…
I’ll keep that in mind.
What I usually do is “intersect faces with model” after making the group I’m trying to intersect into a component and duplicating it (alt-move), so that I can tell right away if an intersection was successful by looking at the iteration that’s on its own.
I’ll repeat the process with the other group if I need the (or some of the) faces that result from the intersection.
I thought this query was going nowhere, due to the time it took for the 1st reply to come in. Glad to see I was wrong to despair…
What I’ll take away from this is that sometimes scaling to 100x isn’t enough.
Again, thanks for your time and skills.
BTW, in case you have any pointers, this is the shape I’m trying to reproduce:

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.