Curved Surfaces change to 'Frame'

render
modeling

#1

Hi All,

I am still finding my way with sketchup.

I am confused by the behaviour of a curved surface.

When I move an edge across the surface the face disappears and a wire frame appears in it’s place.

Why does this happen? how can this be prevented?

Before -

After -

Rebate Door Master.skp (218.1 KB)

Thank you for any advice you can give me.


#2

I don’t understand which edge you are moving and in what direction. Unfortunately your link to the SKP file is no good.


#3

Hi DaveR I have added a before and after and have re uploaded the file. Mike


#4

The problem is the segments in that arc are too short to allow SketchUp to create the faces. The radius of that arc is only 2mm.

What is the goal of copying the arc over? Are you trying to finish the cope cut?


#5

Ah ok so I need to scale up and then scale down again. I understand that. Thank you for explaining that.

What I am trying to do is make the ‘push’ cut through the ‘pull’

Sketchup stops this from happening with a red massage saying limiting the extent of the push.

So I was attempting to deconstruct the curves then reconstruct them so that they fit together. I am sure that there must be a much better way of doing this but so far I have not found this in the help nor in the forum.


#6

Scale up and back down is one way. I’d make a component of the whole rail, make a copy of the component and scale that up. Do what needs doing, close the giant one and delete it. The original will also be done.

After you scale up, you could do what you planned. Or you could use the Push/Pull on the face as you tried initially. Hit Ctrl (Option on Mac) before starting to Push/ Then extrude up beyond the profile. Select all of that geometry and use Intersect Faces>With Selection to make all the required intersections. Then erase the edges you don’t need.


#7

Hi DaveR,

Excellent that worked perfectly.

I am still unsure as to the difference between intersect model and intersect section. I used intersect model.

Thank you for your help.


#8

Either will work but I usually use With Selection because I can limit what faces are involved. Not a big deal for your model but for some of the complex stuff I draw, it’s a time saver to reduce the selection to just what needs to be looked at for intersection.


#9

When you intersect one set of geometry with another, sketchup has to test each face in one set for intersection with every face in the other set. So, the amount of computation grows as the product of the number of faces in the sets. Anything you can do to reduce the amount of geometry involved will dramatically reduce the computation time.

Intersect with model checks your selection against everything in the model, much of which is too far away to have any possible intersections. It’s easy but very inefficient.

Intersect with context limits the test to the currently open group or component, which has the dual benefit of reducing the amount of geometry and excluding nearby or even overlapping faces that are outside the group.

Intersect with selection gives you the finest level of control because it not only stays within context (you can only select entities in the current context), it also ignores anything you haven’t selected.


#10

Hi

That is a very useful explanation. I will in future use intersect by selection.

Thank you.