Creating text tables in Layout?


#1

Can anyone tell me how to create a text table in Layout? I need to create a plant list for a landscape plan.
I have been able to insert a PDF list, but have not been able to preserve the size of the original when fitting it to the page. (I can preserve the size of the plan it is being imported to, but not the new list).


#2

Layout has it’s own Text Table feature… see… >Text >Table…

Was there something you needed which this couldn’t provide?


#3

Sorry, Jim. I choose TEXT from the menu, but I do not see TABLE anywhere


#4

Hi,

You have to start off by drawing a ‘text box’. . . After that the table option becomes highlighted in the text menu, so that you can select it. Ultimately, as you see in the screen capture below, a dialog box displays so that you can format your table.

It might also be necessary to have some text in place (within the text box you made), before the value fields become active in the Tables dialog window. This happened early on when the fields were originally set to 0. After use where values aren’t zeroed out, the table generates itself according to the last settings used.

Once you kickstart everything off with that, things go pretty smoothly. . .


Take Care,

Jim


#5

My jaw dropped. Is this a Mac thing? Cannot find this in my 2015 (Windows version). People have been wishing for a table tool for years.

Anssi


#6

It’s been a Mac thing for years. As is PDF, since PDF has been a part of Mac since Mac OS X, as Display Postscript was a part of NeXT since 1988. :slight_smile:


#7

Hi Anssi,

[Original comments deleted]. . .

I didn’t realize what you were talking about, I assumed that Windows also had this feature, but without the quirky behavior which is seen in my animation attachment. I thought jaw dropping meant how the table was initiated. not how it’s only available on the Mac platform (but not on Windows). . . which is what I now assume (having reread the comment above in light of what followed below mine).

Anyhow, I just want to be clear, what I originally said could be interpreted as bragging of sorts. And that’s definitely not something I would have done. I just thought I was highlighting a quirky user experience on the Mac, while assuming that things worked perfectly on Window – it never occurred to me that this option wasn’t on Windows at all. I hope that didn’t come off the wrong way. and I’m truly sorry if it did.

I don’t know the history of SketchUp’s development as well as others around here.

Anyhow, I deleted my original comment because the context is different from what I originally thought.

I guess this animation, for whatever reason doesn’t playback automatically. But it does when you click on it. I’ll have to figure out how these animations work at some point a little better, for now it’s probably appropriate given the topic.

Take Care,

Jim


now it’s playing back, go figure…


#8

To expand on what Barry said, this feature is Mac-only at the moment because it’s built in to the Mac text editing system. The LayOut team has wanted to add a better text-table feature on both platforms for a long time, but obviously it hasn’t happened yet.

Some people make tables by first creating the table in a text editor (such as Word) and saving the file in an “rtf” format. Then, use the File->Insert command in LayOut to insert the contents of that document into your LayOut document.

Thanks,
Marc


#9

Thanks, Jim. I’m able to start a table, but (see screenshot) the right side of the table runs completely off the screen and I am unable to resize it. Any suggestions?


#10

Thanks, Marc. I can insert a PDF file, even drag-and-drop it onto the Layout page. It needs to be size, cropped, etc before the insert (not able to preserve the size of the original when adjusting it).

I’m not able to save as ‘rtf’. I’m on a Mac - is that option for PC users?


#11

On a Mac, the “TextEdit” application will save documents in RTF by default. What application are you using at the moment?


#12

Thanks again. I see how it works now.
The application I’m using is Pages. It works well for creating text tables, which doesn’t seem possible with Textedit files.


#13

I don’t really know what the problem is with that extended row in your screen shot.

The only Idea I can think of is to try and zoom out as much as possible and maybe that will bring the outside edges back into view.

Otherwise, See what happens when you open up the layout file I’ve attached here. With any luck it will read the same for you as it does for me. . . and maybe this might have the effect of resetting the text table on your machine. . . and hopefully, it will open up this same way the next time you use it. . . It looks like it’s always saving the last settings made.

Empty Text Table.layout (7.7 KB)


#14

Thanks again, Jim. Tried zooming way out - no luck. The greyed-out lines extend to the end of the doc, but when selected, the blue lines seem to stretch infinitely off to the right.

I was able to open you file - thanks! Creating a text table afterwards with results as before.


#15

I hope the text table feature shows up in the Windows version soon. I copied and pasted a Word document into a LayOut page, but the behavior of the text was so odd and erratic that I gave up and pasted in an image instead.


#16

When the text box tool is activated there are two options, the text can be in a text box or it can be a free text. The table size is undefined when the second option is selected. See enclosed images for further explanation.

Hope this helps.

PS- Maybe LayOut should prevent adding tables when the free text option is selected.


#17

I agree - LO should prevent adding tables when the free option is chosen.

So, please tell me how to not have the table hidden with the red arrow.

Thanks!


#18

I think I got it - just need to enlarge the text box - or is it the table? to show the entire box and
remove the red arrow

Thanks for solving the problem, Yogesh!!

Todd


#19

Hello, this is my first post. To anyone interested, I just discovered it is possible to crate tables by making it in Microsoft Excel and dragging it into Sketchup. Once in there it is possible to edit them without opening in excel, not like an embedded object. Sketchup Pro V 15.2.685 64-bit Windows 7 Enterprise N.