Copy/Paste from 2016 to 2015~ no go


#1

Hello just wondering if anyone else has noticed or has tried to get a part copied to the clip board in 2016 to paste in place or anywhere into a 2015 file. I can model a part in 2015 and do a copy/cut and do a paste in place in into 2016. But not vise~versa??

Also and a bit funny I could not get it to load DrawHelix14 as it has an .rb extension, BUT it did load the French file version… That’s how I noticed the clip board issue, I was using 2015 to draw the helix and shoot it over to 2016. Trying to move it back is when I noticed it. I could not even get a rectangular box made a component in 2016 to copy / paste either into 2015


#2

It seems like geometry can copy across, but components have changed in some way.


#3

Have you checked the new extension security settings in the preferences?


#4

I can not get either, a component or raw geometry to go from 2016 and paste in 2015… I did the component first so I could see it in the component browser, or tray as it is called now.


#5

Yes I have seen the three options to select from. But would selecting approved unidentified extension or the first selection cause this effect on a SU component or raw geometry. I have tried a default rectangle & a circle and could not copy or paste and place any un-modified geometry. Going from 2016 to 2015. I would never apply the third choice and only loaded the extensions ( Fredo’s Tig’s and C. Fulmers ) that were working in 2015.


#6

Geometry is failing for me now too, not sure why it worked the first time.


#7

I’ve tried the 2016->2015 copy and can reproduce the problem with all kinds of geometry (raw, group, component).


#8

I understand about the extensions, my main concern was the paste and copy issue. I only stumbled upon it by using 2015 files with extensions I new worked. Pasting that geometry to 2016 when I did not have any extensions loaded to 2016 yet. Trying out the new inference features in 2016. It not sending them back is what I was wondering about. Thanks…


#9

it’s a little off topic, but ’ Unrestricted ’ is what you have been doing before v16 and there are many good ‘safe’ plugins that need to be updated to comply to the new ‘regime’ …

Even Trimble recognises this by setting the ‘default’ as ‘Unrestricted’ for v16…

going back to use them in v15 is every bit as ‘Unsafe’ as allowing them to work in v16…

your making life unnecessarily more difficult…

john


#10

Nobody has hit on this yet, but we need to remember that older releases cannot read or write to newer versions of the program, and this makes it improbable to copy and/or paste from v2016 to v2015. In cases where you want to accomplish this, the v2016 file should be saved as a v2015 file and then the copy / paste operation should work.


#11

Thanks for the explanation…hence this:

Now it is making scene, thanks and…Peace…


#12

It’s never been possible to copy/paste backwards. You have to use the save as function to make everything compatible for any older version.


#13

Virtually all major apps maintain backwards compatibility going back at least several versions so they don’t shut their entire user base out in the cold every time they undergo an update. This is possible because the file format and data attribute characteristics of prior versions are well known to the developers when they create their new import filters.

Not so, of course, with frontwards compatibility, which is not possible; it would entail some kind of weird clairvoyance on the part of the developers, who would have to predict changes to the software and the data structure to make, say, SU 2015 able to support data created in the as yet non-existent SU 2016.

It’s hardly surprising that the same backwards-only compatibility applies to clipboard data.

-Gully