Component behaves as if it is part of two different layers

I have a model where components added to one layer are color coded as if they are part of a completely different layer. If I turn on “Color by Layer,” these component are purple even though they are part of the teal layer. Hiding the teal layer causes them to be hidden as one would expect. But these same components are also hidden when I hide the purple layer.

To make matters even worse, the components that ARE actually part of the purple layer are color coded gray.

Is this a known issue?

All items should be on Layer 0. If you create items on Layer 0 and then group them and put the group or component on Layer 1, you should have no problem. However, if you now explode the Layer 1 group, the items will now be on Layer 1 instead of Layer 0. Re-grouping them and moving them to Layer 2, the group is now Layer 2, but the items are still Layer 1.

If you move a group (or component) to Layer 0 before exploding it, this will eliminate the problem.

2 Likes

How about sharing the SKP file so we can see what you’ve got? It does sound as if you aren’t using layers correctly.

1 Like

Please keep in mind that only 3 things in SketchUp “own” geometric collections.
These are the top level model, and the definitions of components and groups.
(Whilst ignoring Image objects for this discussion.)

Layers are shared display behavioral properties that are used by entities.
So an entity has a setting that can point at one layer to use at a time.

(You’ll just confuse yourself if you continue to think of objects being on layers, or moving objects to layers. But you’ll also notice even the gurus and sages “slip up” in this regard.)

As said above, keep all geometric primitives set to use "Layer0" and only assign group or component instances to use other layers.


There is a special case when primitive entities might need to be temporarily assigned to use a layer other than "Layer0" and this is just before exporting out to another file type for use usually in a 3rd party CAD application. But the good exporters will do this for you and undo any change to your SketchUp model.

1 Like

Thank you all very much for taking the time to respond! I was definitely doing a lot of grouping and exploding and treating components as if they “belong” to a layer. I also didn’t appreciate the fact that groups are themselves entities that use a particular layer.

I ultimately just deleted each layer, which forced all of the entities into Layer 0 as suggested and then changed each component/group to use the appropriate layers from there, and that did the trick.

2 Likes