Commercial Interior Tutorial

Can anyone advise why the follow me is not following the profile according to the tutorial mentioned above?

01_Co-Work_2D Plan.skp (621.9 KB)

If you hide the rest of the model you can see that the path you are following doesn’t match the inside of the walls. It’s more following the exterior.

Your model is in kind of tough shape with loose geometry nested with groups.

Also some incorrect tag usage. You want to keep all edges and face untagged. Best to stay on top of that as you do your modeling.
Screenshot - 1_9_2024 , 8_45_01 PM

Thank you. I’ve no idea how this happened as I’ve been following the tutorial step by step… Do you have any idea why my path ended up on the exterior and not interior, what I might have done incorrectly?

Regarding the loose geometry do you mean I didn’t make a component or a group?

I’ve no idea how to keep edges and/or faces untagged nor do I understand why I need to do it… Can you mind explaining this to me please so I can get fix what I’m doing wrong? BTW inside the box message you added saying 'Default Tag Geometry: Processed Who Model: 106 Edges 2 Faces, what exactly does that mean?

Can anyone offer some assistance with this or Dave if you’re around. BTW regarding the loose geometry nested with groups that you pointed out; there was no direction in the tutorial stating this should be grouped at this stage of the process therefore isn’t that something that should be corrected by the campus team or whoever puts out the tutorials?

Sorry. I’ve been tied up. I’ll get back to this as soon as I can.

Okay thank you. I’ve been looking over the 3D Model and the skirting is clearly on the inside not on the exterior as you mentioned.

I didn’t say the skirting was on the outside but it looks like you used the exterior perimeter of the building at the path for Follow Me. In some places the skirting isn’t touch the walls and at other places it disappears inside. Here I’ve select the top face of the skirting and its bouding edges.

At the other end.

I think you’re either missing some steps or adding some in. I wish I could have been looking over your shoulder as you did the modeling. It would be easier to identify exactly where things went pear-shaped.

I can only guess that you selected the wrong edges for the Follow Me path. From what I can see you selected the perimeter of the floor plan or at least the floor face for the Follow Me path. There’s evidence of that in the corner where the floor plan has a narrow extension.

Here’s another spot where your skirting doesn’t follow the inside of the room.
Screenshot - 1_11_2024 , 4_28_11 PM

The skirting is also part of the floor geometry. It really ought to be separate from the floor. You can see here it all selects together.

If I were doing this I would trace around the inside perimeter of the walls to create a path. I would also create the skirting as a separate object from the rest of the geometry. Location of the path and profile is critical if you want it to fit the room correctly.


With import CAD line work as it appears you havem you should edit the components, select the edges and faces and set them to Untaggedin Entity Info.

Leaving geometry (edges and faces untagged prevents errors and makes your work flow easier. You don’t have to chase the active tag as you are modeling. Since only groups and components should have tags and Untagged should always be active, you won’t have to worry about parts of a component or group disappearing because it’s incorrectly tagged.

I used a plugin called Default Tag Geometry to remove the tags from the edges and faces in your model. There ere 106 edges and 2 faces that had been given tags at some point. The plugin, which is available from Sketchucation makes quick work of that although you can do it manually as I described. You could just delete all tags and make everything in the model untagged.

I think by the time a student has gotten to that point in the tutorials after going through the Fundamentals and other ones the grouping things should already be fairly ingrained. You need to be making groups or components of discrete objects as you go.

I’m puzzled also about some of the other things I see in your model. For example the gap between the walls at the corner. And why does that long wall run past the corner?

Why are the headers over these doors loose geometry? They should be included in the wall group.

As you are modeling be thinking about what edges and faces should be collected into a group or component.

Hi Dave,
I will read over your response in a few minutes, I just wanted to point out regarding this tutorial. Some things explained don’t work the same with this version of Sketchup. I’ve started doing this all over again from the beginning for example. At the drafting stage, the guy selects everything, makes a group, then selects only the floor to invert and make it a group on it’s own. When I select invert floor I can’t make it a group, I don’t have that option. Do you think that’s why the skirting is getting messed up. I just wanted to share this with you before moving on and having this thing end up totally messed up for second time.

Maybe @eric-s would want to comment.

I went to the trouble of finding that part. He is showing what might be called a slightly advanced tip. If you aren’t watching carefully you can get confused.
What he is showing is basically this, but it’s a bit hard to see in his vid.
GIF 12-01-2024 1-05-23 PM

I’m glad you pointed out the loose geometry above the doors because when I tried to erase the lines as instructed on both sides using exactly the same step show my entire model gets deleted. I tried using a modifier with different actions hoping that might work, it did ntohing to prevent the model from deleting along with the lines. I spent so much time trying to get rid of the lines on both sides of the top of the doors that I overlooked grouping the walls above.

To be honest I’m getting really frustrated with this tutorial which depicts one thing yet acts in a totally different way than that explained on the screen.

Perfect, thank you so much for the visual explaination!

Hi guys- just wanted to jump in here and maybe suggest the model/file that SketchUP tutorial has us download and use for this step could be differing from the one that Eric seems to be using in his tutorial. I had similar issues and I am decently familiar with SketchUP (just trying to refine some of my practices to speed up/clean up my normal process). Anyway, just a thought! As the way Eric had things organized seemed different than the way our organization was set up in the downloaded file given to us. Specifically, the weird overlap at the corner of the wall and the window as well as the interior floor selection that was used to create the molding using the follow me tool!

I’m really glad you jumped in, this tutorial is frustrating and totally non-productive!

Why not create a new updated tutorial that actually helps people instead of being knowingly aware that people are struggling with the content presentation errors?

I’m still trying to work though this very unenjoyable tutorial, it’s been an absolute nightmare from the beginning and, to date there has been more than one beginning… go figure.

Just FYI Dave, you had mentioned in a prior text with this image asking me why I hadn’t grouped the walls above the doors. If you go to the tutorial being referenced you’ll note the presenter didn’t group his walls above the door. Just to be clear, I knew to group the walls however, considering I was trying to figure out how to get rid of the lines on either said I overlooked grouping.

I just point this out as a tutorial should cover everything and this unfortunately fails for many reasons!

I do appreciate your time offering assistance to help me overcome this nightmare. Thank you.

It was explained and drawn correctly (for the other beginners and not only).

Commercial Interiors course at

2D to 3D Walls
transcript between min 3:46 - 4:09

> Starting with any one of the doors
> Make sure you are in this inner walls group
> and draw a rectangle from side to side
> delete extra vertical face
> and then PushPull down
> - - -
> and then just erase the extra lines that show from inside.


Understood, I will go over this ‘once again’ to ensure I didn’t overlook the point you made.