Changing shape of windows

I am changing a few windows from horizontal to trapezoid shapes. Each one is different so I have to do a few of them as opposed to one component only. I am doing them, albeit slowly. Before I progress much further I wanted to see how an experienced modeller would handle this. window .skp (135.5 KB)

Also why does zoom freeze up or slow down. It gets very frustrating when one is on a roll. I purge frequently also.

I’d probably use Box tapering from FredoScale to make it fast.

As for SketchUp getting slow or freezing, that’s typically due to the graphics card. One thing you can do to help is working without materials displayed by using Monochrome face style.

1 Like

Okay, I’ve added that extension and am playing with it, works great. one question, how do I snap it to the right dimension or guide line in this case, the bane of my SU existence…

I typed in a value but it’s in decimals where my measuring tape is giving me fractions.

SketchUp recognizes decimals even if you have units set to Fractional. It also recognizes metric units even if you have Units set to imperial.

Probably the easiest way, though, is to set out a couple of crossing guidelines so you have an intersection to snap the handle to.

1 Like

Ahh, I see now. I had my guidelines going in the other direction. I got it now. Thanks again Dave for all your help.

1 Like

In versions of SU earlier than 2019, there’s a bug - see this post:

I think, but haven’t checked, that the bug is fixed in SU 2019, but it exists in Make 2017.

It’s never been a problem for simple imperial/customary US measurements in whole inches or feet.

But it looks as if it has NOT been fixed in 2019 for more a complex legal imperial/US customary units measurement, that are simply wrongly converted to metric.

With millimetre units, I draw a line and input 1’1 3/4 in the measurement box.

I get a line 306.55mm long, which is 12 inches (304.8mm exactly) plus 1.75mm.

This is simply WRONG and a BUG.

However, if I put in the inch mark as well, it does now get it right: 1’1 3/4" converts correctly to 349.25mm.

Everywhere else, SU can correctly parse foot/inch/fraction lengths. Just not in a metric unit model when input into the measurement box, and omitting the inch mark.

At least it does now work if you put in both unit indicators, which is an improvement, I think, over previous behaviour.

With your settings what happens if you enter 1’1.75?

Same as if you enter 1’1 3/4 without the inch mark - 306.55mm.

Interesting. For my imperial inch settings, the decimal format works well. So we keep learning. Thanks.