Can't intersect faces

Intersections of faces produce edges but not a separate face:

example1.skp (90.8 KB)

  • It’s not a small face issue, I double checked
  • Intersect Faces -> Intersect with Model -> no changes

The same issue:


example2.skp (87.7 KB)

  • Why does it happen?
  • Is there any way to fix it (get a separate face from intersections) using Ruby SDK?
  • Is there any way to detect such situations using Ruby SDK?

Thank you!

I think for some reason the lines are not exactly touching the faces. You can fix it by selecting the lines, Cut, Paste in Place. You may have to redraw a line or two to heal it after that, but the faces will be good.

I tried

  • cut and paste all faces
  • redraw all edges
    But nothing helped. Could you try with my SKP in the original post?

I checked all vertexes via API - they are on the face

Hmmmm…

I guess I’d have made the dormer without the horizontal face inside to start with. That would make it easier to make the hole in the roof.

I have a lot of such elements in many modesl and it will take a lot of time to find and fix it manually. I tried to use Solid Inspector2 and RubyAPI to automate the cleanup process, but I need to intersect faces somehow first. Is there other way except manually remove and then add edges?

I did use your model, and it was Paste in Place I was saying to do. Paste is unlikely to put it back in the right place. Dave has a simpler work around.

Not sure what introduces the issue.