Cannot Anchor Trays, SUPro Studio, Windows10, 23.0.397

Did you install using the right click on the Install file and Run as Admin method.

@Box, thanks for the suggestion to install as Administrator I will try that. … I’m getting older and it is harder to remember or keep up with all the “tips and tricks”

1 Like

No luck. Totally uninstall SU2023. Installed 2023 Studio as Administrator…

Can you anchor the Default tray?

I just made a custom tray and dragged it away from the right side. As you can see, double clicking on its title bar results in it docking on the right side.
tray

Dave, I tried that. The tray resizes and is moved to the right-side of the screen but will not anchor to the right “margin” and there is no thumb tack in the tray’s titlebar.
See above screen capture.

I submitted bug ISS-0675.

Something’s goofy. That’s fer sure.

Doubleclicking in the titlebar will place the tray to the earlier position
Do you see the docking symbols?
If you create another tray, and then drag the tab somewhere else, do you see the docking symbols than while moving the second tray back over the default?

@MikeWayzovski
Nope! Dragging any tray to any margin will not work.
No docking symbols either.
I have also deactivated all extensions except those installed by SU Pro Studio.

Do you have multiple screens set up?
Try to switch the main screen in Windows display settings or drag the SketchUp viewport to the other.
The docking symbols might show up, then.

What I have done that seems to have worked. Hooked up a dual monitor. Changed the resolution for each by going to lower resolutions. Moved SU to secondary monitor. Expanded SU to Maximize. Made secondary monitor the only display, opened SU. Changed worked space preferences by UNchecking Use Large Tool Buttons and later rechecking them, deleted all my custom trays and then created a new one, Switched display back to both monitors and changing the Display Resolution of both back to their “Recommended” settings (1920 x 1080), and Unchecked both boxes for Graphic Settings and later rechecked them.

Results:
I can now double-click on the Title Bar of the custom tray, the Pin appears and by clicking on it, the tray docks.
The only the that does NOT work is getting the docking Symbols to appear.

1 Like

There is also a difference in getting access to display settings on Windows, you might wanna experiment with [Windows] key + P

@Mike:
Windows-P did the trick, now the docking Symbols appear.
Thank you!

However, it seems the docking behavior has changed previous versions of SU, for example, when docking one tray with another tray or trays. Is that true or is it my imagination? If so, is there some where this is documented and perhaps a video demonstrating how docking is supposed to work?

1 Like

One thing I notice that I don’t do is use the Large Toolset toolbar. It has a weird width and height that might confuse the GUI.

Try switching that off when adjusting or docking trays and panels.

YES. SketchUp on Windows has been migrated to use the platform independent Qt framework.

And yes there are still outstanding UI bugs from this migration.

For the general public, no, as it’s an “internal implementation detail”.

But it is so important a change that I feel it should have been a bullet item on the release notes at the least.

SketchUp still has issues with 4K and 5K monitors. It also still will only support display scaling up to 150%. (There should be an open issue to support higher scaling of 200%-250% for 4K and 5K displays.)

And there are still problems with multi-display setups, especially where the display scaling or resolution differs from display to display. (Again, there should be open issues for these various problems.)

Currently, SketchUp does not support 5K on windows because it isn’t really supported by the OS. HDMI supports only up to 4K. If you connect a 5K monitor with HDMI it isn’t really 5K but a scaled version of 4K unless you have special cabling and only one 5K monitor connected to your win desktop. If you have a mixed monitor setup then graphics stability is an issue in general and not just SketchUp.

Right now, the scaled max support is 150%. The goal is to officially support 4K w/ 200% scaling and we are working towards that goal.

Thanks, Kath

2 Likes

Thanks for clarification Kath.

This made me check my CPU specs for it’s Display Port capabilities.
I found that I have an old DP version that will only support a bit over 4K res at 60Hz.

Hey Dan, I figured you would be interested. HDMI 2.1 will support the higher graphics but then you need a better graphics card to support the higher DPI as well. I just got used to 4K and it’s really expensive to move up to 5K. ;)K

I can’t see as if I’d need a 5K display. The 4K units are coming way down in price lately.

Really, the main delay has been the lack of 200% scaling support for SketchUp.

(Without scaling everything would be about half the size. Ie, Currently I’m running FHD on a 25" external display and I’m looking at going up to a 28" 4K UHD display. This will shrink what I see now down into a 14" diagonal portion of the 28" 4K UHD screen.)

EDIT: I’ve come to understand the stores / sales are misrepresenting UHD displays as 4K, which is a Film industry standard of 4096 pixels wide. UHD is 3840 pixels wide and twice the 1920 pixels width of a FHD display, and also twice the height so it has 4 times the screen space as FHD. It ought to be termed “4X” not 4K.

The current 16:9 or 16:10 ratio 5K displays are Aimed at colour critical applications anyway (colour grading or photo editing) and are totally overkill for SketchUp which can’t use the wider colour spaces.

Besides the higher resolution screen, the more powerful machine you need driving it simply to render the SketchUp viewport.

I’m looking forward to that extra bit of scaling to become available.

1 Like

I was going nuts trying to get the default tray to show back up on my workspace after I deleted it by mistake.

Got it to show up but it wouldn’t anchor until I noticed a “floating” anchor (can anchors float? :slight_smile: ) and clicked on it - voila - it’s back where I wanted it.

Thanks, all.