Bleed Thru when viewing from a distance

I am “building” a house in Sketchup Pro. When viewing the plan from a distance, I can see the outline of wall studs and rafters under the sheathing. They disappear when viewing at close range. Is there a way to prevent this?

It is partly the nature of how 3D graphics work. The issue was somewhat improved in 2023.1, so if you are not on the latest 2023, or on 2024, you could try those, and see if the issue is less noticeable.

The other solution is to give roofs and other elements some amount of thickness.

@PaulJackson, or apply ‘Tags’ to objects that you don’t want to see in certain views by turning them off.

If you are using medeek then you should be able to turn off the framing tag layers.

The SKP lines get thicker than the geometry at distances and the lines show through.

Here’s a basic example.

Also make sure you have built your house close to the original axis in the SketchUp file, this becomes more noticeable the further away you are from that

Thought I would just check if this has changed with the new graphic engine in 2024, not yet it would seem.
GIF 8-05-2024 2-34-03 AM
Off screen selection is Hide.

1 Like

In games, it’s smart enough to not draw hidden lines at all which increases performance which would be a win-win for Trimble…
I believe the term is occluded geometry or occlusion culling.

Thank You for the comments. I’ll use these examples.