Axis constraints

I am having a little trouble controlling the way the drawing tools align themselves by default. To explain- I am following tutorials which require me to draw a circle so that the face is flat in line with the red and blue axis so that I can pull it up to create a base for the chess piece I am modelling. For some reason, every time I open the circle tool, it locks its plane to the green axis so that it’s face is in line with the green axis.

I can use an existing flat surface as a reference, holding shift to lock it to get around this. How do I choose what plane it is drawn on without doing this, if there were no other surfaces to reference for example?

Just trying to get a firm grasp of the basics here.

Thanks in advance.

1 Like

After selecting the circle tool, tap the up/left/right cursor keys to lock to blue/green/red axis. (Before clicking to place the center).

1 Like

Thanks! Sorted, that does work after all…I don’t think I clicked the right arrow directions when I first tried it but I have got it to do it now, thanks!

1 Like

Aha! I’ve just realised why it didn’t work the first time I tried it- for some reason, the arrows on my keyboard don’t seem to correspond to up and down in the way I would think. For example- the left arrow key locks the axis constraints to the up and down! I am thinking that perhaps I have positioned the origin axis incorrectly?

Blue is up.

Right click on an axis line. Is Reset black or gray? If black, that would indicate you’ve moved the axes. click Reset to fix it.

‘Reset’ was black so I clicked it and it reset the origin. I then tried the axis constraints again using the keyboard arrows and it was the same result as before. :thinking: The left arrow key locks to the green axis (up and down). Kinda strange huh? I guess it doesn’t seem to matter really, as far as I can tell…I’m just worried that something isn’t set correctly which will cause problems down the line. As I am too familiar with this kind of thing biting me in the butt later on. HaHa

Hold on…blue is up, not green? Hmmm… I’ve still got blue as a horizontal even after a reset?

It is just the axis within the editing frame of my component that was still different. I didn’t realise that a component had its own independent axis origin!

The Blue axis is up/down, not the green.

The component gets its own axes and origin when it is created. The axes are aligned with the model axes. The default location is in the lower front left corner but you can move it as needed. If the component is rotated after creation, the axis alignment may not align with the model axes.

In addition to moving the component’s axis origin, you can realign the axes any direction you want by means of the right-click Change Axes context option. This can be very useful to align the compoent’s axes with the major dimensions of a component so that you get a tight bounding box instead of one that follows the global axes directions.

1 Like

Just had a thought. if the component is something you got from the 3D Warehouse, it’s entirely possible the author created it in some weird orientation. I see that frequently with components that have been drawn laying on their backs on the ground plane. This makes them more work to use and can give the impression that “green is up.”

Also components that have gluing properties get a different sort of axis alignment that has green up. They don’t have a normal blue axis, though.

Yes, I am getting to grips with this now👍

No, it is a component I have made and am working on, but I look forward to the joys of figuring out the settings that have been used to create all the models in the 3D warehouse! I’m sure that will be a delight! haha

That’s good. So you have full control over how it is made. This means you can make the component so it is easy to use in future models if you’re going to do that. Properly locating the component’s origin and orienting the axes is a huge part of that.