Axial alignment

I’m trying to draw a gearbox, and I’m having difficulty aligning the gears along the shafts. Is there a method for doing this more easily?

Make your ‘gears-wheels’ as components.
Make their insertion point ‘centered’.
You can also add a central line through that point - to allow easier movement and snapping later…
If part of the inner hole in the gear is a circle you can also get a Move inference ‘center’ by hovering over the circle briefly, snap to it and relocate as desired.
Also make the ‘axle’ cylinder as a component with a central line and again a centered insertion point.
You can then ‘snap’ the pieces together.

You can also use guide-lines, xray, section-cuts etc to help align objects…

(… as TIG mentioned above)
And do take advantage of using the X-Ray style to be able to snap to geometry “inside” the shaft, its center line.

Thanks for the answer, Tig, but I’m still stuck! I’ve made the gears as components, but I can’t see how to “make their insertion point centred”. How do I add a central line?

Presumably you’re aware all circles, arcs, and other curves in SketchUp consist of straight line segments.
One can use that segmentation to their advantage in aligning geometry.
Look to the top menus and click… View > Hidden Geometry
Use the now visible axial lines of the shaft and gear bore for alignment.
You might also infer to those axial lines to create temporary geometry for alignment.

Face Centroid and Area Properties — Extension Warehouse
Adds a true centroid guide point and crosshair to a face.

Example Ruby Scripts — Extension Warehouse
Adds the item Point at Center to the context menu of circles and arcs.
Like its name, it adds a guide point at the center of arcs and circles.


I am trying to do something similar, aligning hollow cylindrical standoffs in pockets on a plate. After two hours I have three of six done and little clue how I got there.

I have followed all of the suggestions in this thread and installed the two extensions suggested by Geo, never do I get a centerline when I turn on hidden geometry. Each time I try to align the standoffs in the pockets I can grab one centerpoint on the standoff but never the centerpoint in the pocket because it is now covered with by the standoff. TIA for any help on this one.

BTW: All of the standoffs are components

You didn’t follow all suggestions, otherwise you would be able to look “inside”, so once again:

[quote=“Wo3Dan, post:3, topic:1734, full:true”]
(… as TIG mentioned above)And do take advantage of using the X-Ray style to be able to snap to geometry “inside” the shaft, its center line.

b.t.w. turning on show ‘Hidden Geometry’ can only reveal what has been created. If a centerline isn’t there it can’t be displayed. You need to create it yourself in advance. Hence my remark above: “…its center line”

Thanks all, got it to work finally. Guess a newbie should try to solve these issues at 1AM huh?