Autosave 22

I have autosave set up to autosave every 5 minutes, my preferences are set to save to C:\Users\nev\Documents, however there’s nothing in that folder, there’s no autosave file in there i can see. I’d closeddown my computer and accidentally not saved a drawing. Thinking its ok as there’s autosave only to find there isn’t.


these preferences are the default save location when you first save a document, not the autosave location.
paste this in an explorer window to find your autosaved files
C:\Users\%USERPROFILE%\AppData\Local\SketchUp\SketchUp 2022\SketchUp\working\SKETCHUP\RecoveredFiles

autosaved files are also viewable on the welcome screen window when you start sketchup. If you disactivated it, go to preferences > general and tick show welcome window if you want it back, ortherwise go to help>welcome to sketchup…

Thats great, if only it autosaved i’d still have my work. As a comparison, If I’d done the same with autocad, i’d have the saved version from the last save that day in the temp folder.

For some reason Sketchup only had the version from my save the previous day meaning it hadn’t autosaved every 5 minutes. Either that or i’m misunderstanding the workings of autosave.

it autosaves every 5 minutes unless :

  • nothing changes in your model

  • you manually save your model

check if you did’nt save your model (perhaps in another location) at some point

also check your .skb file located where you skp file is saved, copy it, rename it into .skp and open it

That’s another mystery, there isn’t one. Only the skp, no skb to be found.

in your autosave preferences, any chance you unticked the “create a backup” as well ? that would be a perfect explication for your lack of skb.

Annoyingly create a backup is still checked and still no skb.

You may misunderstood the meaning of this. The .skb file only will created when you save your file, beside the original (.skp) file keeping your last version before save.

Auto-save tells SketchUp to automatically save changes to your model into a temporary file at specific time interval. This autosave file is located elsewhere (as Paul write above).

See also:
Setting Software and File Preferences | SketchUp Help

So understanding this, there should be an skb file created when i initially saved the drawing? I’m trying to work out where that might be as its not in the same folder as the SKP.

Also, there is no autosave file in the folder as listed above either.


I’m going to assume you aren’t using windows 8.1 so can you update your profile information fully. It helps us help you.

When you installed Sketchup did you use the Right click Run as Admin method. If not you may be suffering from permissions issues.

Close sketchup and layout.
Find, probably in your downloads folder or download a new version of the Installation .exe
Select it, right click and choose Run as Administrator, follow the prompts and when given the option choose Repair.
Reboot your computer.

The autosave file is deleted when you close SketchUp. It is preserved only if SketchUp crashes.