Assigning P as a shortcut for Push/Pull hang SketchUp

When I try to replace F1 which is the default shortcut on my version 2022 of SU, the software hangs. I have to force quit.

Could it be an extension/plugin ?

Usually, if P is already assigned to another tool, I receive a message to this effect but not in this situation.

I have no problem with SU 2020 and 2021, in French, using the same French Canadian keyboard. These tow versions also have some plugins.

BTW Shortcuts was translated as Raccourcis in 2020 and 2021 but is not translated in 2022, why ?

Is it possible that P is assigned to something else and the message regading that is opening off screen?

1 Like

(I’m on Windows, but should be similar on Mac)

Basically the P is a default shortcut for Push/Pull. (According to Quick Reference card in this article)

If you have F1 assigned, that means you already changed it during your initial setup or later. Or imported shortcut settings by loading previously saved preferendes.dat file.
(It is also possible that the installer automatically doing shortcut migration… I do not remember if it is the case or not :blush: )

What I would try:

  1. Export your current shortcuts. (backup)
  2. Reset All
  3. Restart Sketchup
  4. ( Check if P works, and/or if you can change any shortcut . )
  5. Import back shortcut from the previously exported file.
  6. Restart Sketchup
  7. Check If you can change any shortcut …

image

1 Like

No, I checked with another shortcut and the message appeared on my screen.

1 Like

Unfortunately not.

See this screen capture.

I have no way of saving or loading shortcuts with this dialog box. I probably can find it in the Library folder.

After checking the Library/Application support/SketchUp/SketchUp 2022, I found nothing about shortcuts.

No, I never played with shortcuts in the past.

It should be stored in SharedPreferences.json. (if I remember right in my previous readings…)
Edit: I find it now:
https://forums.sketchup.com/t/keyboard-short-cuts/38265/9/

Then it’s worth it if you try the Reset All (Tout Réinitialiser?) function and restart the SU… to see ? !

I deleted the json file the restarted SU. It started OK but I lost a few tools palettes. I got them back and, to keep them for the startup I had to save my workspace. This worked OK.

As for using the Reset all, it also worked and I got P at the default shortcut for Push/Pull.

Thanks everyone for your help.

1 Like