Animated water

Hey everyone

I have been working on a house with sketchup and archicad for a while now, and I am using vray to create photorealistic renderings. However, I recently started doing animations with vray, and I think that it works fine. My next challenge is to do an animation in which the water inside the pool is animated and not fixed. I cannot find any tutorial on how it is done, but I saw the video on youtube. It gives absolutely no indication on how they made it, but that’s basically what I’m aiming at.

Any ideas ?

1 Like

If you read the comments, people are asking the same question. Why they posted a video without explanation is beyond me. Anyway, in the comments, they link to the material on their website (registration/login required) -

From there, it should be as simple as applying the water to a surface and rendering out an animation. My quick test shows the water movement or frame rate is waaaaay too fast. When I have a moment, I’ll see if I can find the setting that dictates the movement and try to adjust. If you happen to get to it first, please post your solution here for others that may have the same questions.

1 Like

Oh okay well I tried to render with the water texture and it wasn’t moving at all, but maybe I should try again with a simpler model to first see if I can do the same thing that you did. And yes, I will keep you updated if I find how to adjust the speed settings

Ok, I think I found it…

Open up the material in the Asset Editor and for both TexWater#2 and #3, change the ‘movement rate’ down from 12 to whatever you want. You can also change the ‘Wind magnitude’ which will shrink and soften the waves themselves as well. Good luck!


oh whah well done ! For some reason when I upload the material from my desktop to vray, it uploads 2 different files, one looking like water, the other one is just black. from there I apply it to my selection but it just doesn’t work any further.

Weird. Take a look at my file and see if that helps. I assume you’re using 3.6 or above for V-Ray?wateranimatedv2018.skp (584.0 KB)

1 Like

okay so i got it to work, I think the settings were so off that I couldn’t see anything moving. Thank you a lot for your help !

No problem. Can you mark this as solved when you get a chance?

1 Like