Active Section Cuts and Styles

When creating scenes from Section cuts, I obviously always want the Scene to remember the Active Section Cut so that when I am creating my views in Layout, I can easily select the scene I want. Therefore it seems obvious that every section cut requires a separate style. To explain further, I am creating interior elevations which means at least 4 Section cuts per room. The number of Section Planes is a bit overwhelming, so it is critical to get the Scenes to work correctly so I do not have to fuss with the Section Planes. So in order to maintain the Scene, I have to make sure that I am saving a new Style each time. That is a lot of Styles…

Is my thinking correct? Or is there an easier way?

No. The active section cut is a scene property not a style property. The style only determines whether or not sections are displayed and associated settings.

1 Like

Some people use Position Camera to get around the problem.

1 Like

Well neither of those answers really explain what is happening. And now I have an additional problem. Several of the Section Planes are in my Building drawing in order to create building sections. To create interior elevations, I imported the Building drawing into a new drawing called Interior Elevations and added all the additional Section Planes. The Section Planes that are in the Building drawing are active for some reason - or at least one of them is active. I opened the Building drawing and made sure View Section Cuts was not selected and saved it. I then opened the Interior Elevations drawings and reloaded the Building Drawing. And yet one of the Section Planes must still be active somehow. How do I turn this off?
As for the Styles and the Section Cuts. I definitely need to create a new style for each Scene or the particular Active Cut that I am trying to view will not be saved.

If you definitely need to create a new style for every be section cut then you are setting things up incorrectly but it sounds like that’s how you want to work. Sorry I got involved.

Example: Nine scenes, nine sections, one style.

sections

1 Like

Dave is correct.

How about uploading the file so that we might better understand your issue?

You mention

Building drawing

and you refer to a new drawing as

Interior Elevations

You mean SketchUp models…?

1 Like

so if you want to make sure that the active section is saved to each scene, you must update your scene, because the information that this section is active is stored to the scene when you update it. if you leave your scene before updating that change, then your change of which section is active will not be stored anywhere.

It does not matter how many styles you make, none of them will store the information of which section is active. ( only as Dave said, the setting to show or not show the active cut. And you dont need more that one style for that)

so the takeaway info is: update the scene.

then this question might arise: you have zoomed and panned and orbited in order to select the section you want to set to the active cut. If you now update your scene then also your new camera position is stored to the scene, and you no longer have that old view of your section.

some different solutions:
1: You update only one of the scene properties, the one that is about sections planes.
2: You reset your camera position to see the section the way you want it, by selecting “align view” when your section is selected, and then update the scene.
3. Easiest way, if you learn to use “outliner”: a) Select that section that you want to set active, maybe you have zoomed out to find it. b) select that scene again, to reset the camera position. That section is now still selected even if you cannot see it. c) right click that scene in “outliner”, and select “active cut” d) update the scene.
4. If you know the name of your scene, you can select it in outliner without the zooming out to find it, and then just set it active and update your scene.

Dave,
This is of interest to me becuase, based on a recent thread, I switched to a single default style in SketchUp to simplify. I have multiple styles to choose from in a folder which I can access in Layout.

In the example you show, it appears the default style you are using allows for section cuts, maybe a section fill color of your choice and no section planes. So when you created each scene, did you turn on the section planes (from tool bar), select the section plane for the scene and make it the active section cut, then turn off the section planes from the tool bar, then create the scene.?
In this way, no pop-up window ocurrs asking about creating a new style when you create the scene as section planes are off.
Then in Layout, if you wanted to show a viewport of the bed with all of the section planes, you could choose from a style that has section planes ON and section cuts OFF.
Does this reflect what you are doing ?

When I created this example I placed a section cut and created a scene. I could have had the scenes established, added the sections and updated the scenes, too. As you guessed, the active style has section planes turned off so they don’t show in the scenes. Also in this example I do turn off the section plane display manually so the style has not been modified so no Style Warning window when creating the scene. With the style set as I wanted it, I could have skipped turning off the section planes when I made the scenes and selected the third option in the warning window. Then at the end I could have simply selected the style from the In Model styles window to go back to not showing the section planes.

As for going to LayOut, yes I could choose a style for the viewport that is set to show the section planes so no special scene for that is required in the model. At this point you’d still need separate scenes to display the different section cuts but I’m hoping that one day we’ll be able to choose the active cut for a viewport in LayOut. Then you could do show something like all of the required plan section views of a building with just a single scene in the Sketchup model.

Thanks so much. So rather than as I described manaully turning off section planes just use the style to toggle them off. Also, I was not aware of the use of the third selection in the Style Warning when a scene is created. Very useful.

One related basic question, I am using a Mac and I cant seem to find an animation window as you show in your example. I can run the animation within SketchUp by selecting a scene then select “Play Animation” but I dont know how to stop it or pause as no animation window appears.

It can be in some cases although I’ve seen plenty of examples from users who have no idea what the implications of selecting that are. And of course when you select it, there’s the option to disable the warning. Doing that usually creates more problems because the user doesn’t actually manage the styles properly.

It’s been so long since I did an animation like that on Mac that I don’t remember how you pause or stop the animation.

I have created animations before but usually just export them not run them within SketchUp. I looked in several places but see no choice for an animation tray.

Technically you only need one style for the sections, unless you stack viewports like I do. I have 3 section styles…one for a raster view and two for hybrid views that each use a different section fill.

Creating a separate section file and interior elevation file is the most efficient way I’ve found to manage the section planes and scenes.

There are some very easy ways to align views and match properties between scenes that literally take seconds. For instance if you have 3 sections oriented in the same direction and want all three to have the same camera position, visible tags, shadow settings etc, you select the one scene you establish as a base. Then in the scene manager, select (hold shift or control) and highlight the other scenes you want to match. Then simply deselect, then select each property you want to match in each scene. DO NOT UPDATE! Now all the scenes you’ve selected match properties and make your life in LO very happy.

1 Like

I did not mean to sound like I was actually doing things correctly. I was only stating what has ensured my Scenes are remaining how I want them. I would love to have one Style. I see lots of good information here that I will try to follow. I was able to use the Outliner to deselect the active cut from the Building drawing that kept showing up my default no matter how many times I saved the Building drawing with no active section cuts (unless section cuts can somehow be active even if they viewing them is toggled off.) First I need to figure out what I am doing wrong.

Interior Elevations.skp (12.6 KB)

I definitely am updating the scenes after creating them. I do it right in the scene manager window. Or I right click the tab. I am doing something else wrong, and I think it has to do with having section cuts in both the imported Building drawing as well as the Interior Elevations drawing.

I have done something like this in that I have one scene that is the whole model with all the section cuts visible. It has a separate style.

There is no issue with the original reference file having sections. It’s how you are saving scenes and having active section planes selected in the properties. For what you are doing , you only need 1 style.

Once you have this setup as a template, it will be very easy moving forward.

1 Like

If the scene has active section cuts checked, then you use view/toggle off section cut, the scene still saves the active cut, unless you update the scene. What often happens is people will turn off the section cut then re select the scene, negating the last action.

I think I might have a clue as to what makes me believe I have to have all those separate styles. Here is my process for creating a new section. The Building drawing is super large (imported a CAD file that was originally a Revit file), and the actual area of the building that I am remodeling is small. I created a scene that shows the whole building with all the section planes visible. This is the scene I start with every time I create a new interior elevation scene. In order to work on the small area, I turn off the A-ROOF and A-CLNG tags and zoom into the bathroom and place a section plane on the wall I want to see in elevation. I then I right click the section plane and align view. I turn off the section planes and zoom in to set the view like I want it. Then I create a new scene, name it, and update it. The dialog box opens and I select to save a new style because my experience has been that if I don’t, all of my previous scenes will be messed up. But now I understand that I am doing something wrong.
Maybe because I am always starting with the scene that has section planes on and section cuts off, then when I create a new scene, it is obviously asking if I want to change the style. I do not want to lose the style of the main reference scene, but I also do not want to keep creating new styles.

Unfortunately I did not use your templates or follow your setup for this restroom remodel because I originally thought it would be a simple task. But then I had to include the original building Revit file (converted to ACAD and then SketchUp) and the complexity of the project exploded along with the file size. I probably should have just started fresh at that point. Oh well.
What I am learning from this thread is that I need to dive into the concept of Styles because I clearly my understanding is superficial.