Activate viewer subscription

I have Sketchup Viewer on my iPad Pro. I just purchased the AR Viewer subscription. When I touch on the AR/Pro icon, it just reloads the subscription page. When I check in the app store, it shows that the subscription has been purchased.

I am using SU Pro 2020 “Classic” on my iMac, if that makes any difference.

How can I get use of this?

Perhaps reinstalling will. What ios version?


I didn’t try deleting then reinstalling. I’ll give that a try.

No, deleting and reinstalling the Viewer didn’t change anything. Still nothing but the subscription screen.

Maybe @MikeTadros has an idea?

Check this page to make sure your subscription is working:

What SketchUp you are using shouldn’t matter. Only that you are sign in with Apple on your iPhone or iPad.

Yes, the subscription shows up.

Thanks @MikeWayzovski for roping me in. And apologies for @clearplanmodeling for the trouble you’re running into – suffice to say the experience you’re having is far below that of what we aspire to deliver.

First question:
You may have noticed in the AR up-sell screen that pops up when you click the AR button, a link below the “Subscribe” button that says “Restore Subscription” – have you tried clicking that link yet? With any luck, that might resolve the issue.

If that doesn’t fix things, let me know and we’ll try something else.


Hi, Mike

Thanks for the suggestion, but ya, I tried that, and no change. It even says “Restore Successful”, or whatever it is, but no, still no love for me.

Let me know what else you think of.



Alright, I’m gonna pass this off to the real pro, when it comes to troubleshooting. @stephanieSU is gonna take over. Rest assured you’re now in more capable hands. I’ll be watching from the sidelines to ensure we make this right one way or another.

1 Like

I’ve sat in on one of your Basecamp presentations, Mike, don’t sell yourself short! Ha!

Anyway, thank you for helping me out here.


1 Like

I was there, too! **![|1102px;x620px;] |960px;x540px;

Everything in Outliner just says “Group”

@clearplanmodeling Well, all that provides is further evidence that you’re a real trooper!

But you did lure me back in… albeit with the caveat that @stephanieSU really is better at troubleshooting, and at that my chiming in any further comes with the risk of sending you on a goose chase.

That said, we’re chatting about 2 possibilities:

  1. You may have kicked off a 30-day trial of SketchUp Studio that has since expired, and that our app may be confused w/r/t the sequence of entitlement checks that it’s performing. i.e. the app might be reading your expired trial (i.e. ‘free’ subscription) and interpreting that to mean that you don’t have access to the AR feature, and it may not be doing the subsequent check with the App Store’s. So the question there is, do you think it’s possible that you kicked off a Studio trial that has since expired?

  2. You might be signed in to the app using a different email address than the one that’s associated with the Apple ID with which you purchased the AR feature via the App Store. If that’s the case, we’d want you to try signing into the app with a Trimble ID that uses the same email address associated with the Apple ID that you used to purchase the AR feature. This shouldn’t matter, but we still might wanna rule it out.

@MikeWayzovski HAHA! :joy: that one still cracks me up!

Regarding these notes, Mike

  1. I have not signed up for Studio, having been using Pro since at least 2015.

  2. I am signed in to the app store with a different ID and email than my Trimble ID. So, create a new Trimble ID with the same email as is associated with the app store?

OK, I created a new Trimble account using the same email as used for my app store account. No change in the AR add on. Still shows subscription page, I can still “Restore Purchase” just fine, and it still doesn’t work.

When signed in with the email address that is your Apple ID, and now a valid Trimble ID, what do you see if you touch the cloud icon, and look at Trimble Connect?

The Sign in with Apple, and let it use your actual email address, should work well.

So, I was trying to remind myself where the restore purchase was, and hit a snag. You trigger the restore purchase by touching the AR icon that has Pro on top of it, only I got a message about too many devices being activated.

The solution to that is to sign in with the same account, here:

From My Products choose the SketchUp Free one, and View Included Applications. In the panel for AR/VR, click Manage Devices, and deauthorize all devices.

Back in the mobile app you should be able to do AR now. The icon may still show Pro, but exit to Home, and back into the model, and it should be ok.

I find this to be even more confusing, Colin.

The Apple ID I use in the app store is one I created decades ago, and is personal. While it is my active ID for the app store, it is not the iCloud ID I use for coordination across my Apple devices. Apple, in their infinite wisdom, has never allowed for the combining of Apple ID’s.

My Trimble ID, which is a business not personal account, uses a different set of credentials entirely - separate email, password etc. It seems to me, the test Trimble ID I created using my Apple app store email, is now divorced from my Trimble ID that I use to “log in to all things Sketchup” through the Sketchup Pro application.

I DO NOT want to “mix” my personal and professional ID’s.

The link you provided above took me to a login page, where I logged in with my Trimble “ClearPlan” ID, not the one just created using my Apple app store email. Note the screenshot does not list the AR add on for the iOS viewer. Neither does it list my “Classic” Sketchup Pro 2020 license.

I am confused more then ever now…


1 Like

Hi Bob, the first item in “included applications” in your picturer says "SketchUp Mobile Viewer iOS (AR/VR) - wouldn’t that be the AR one that you’re looking for? If you click on Manage Devices under that, does it let you deauthorize them? Unless you’re on Android, in which case it’s the second one.

Hi, Katya, thanks for jumping in.

Yes, by all indications, I should have the AR add on “live” on my iPad. But it isn’t. On the Apple app store, the purchase for the AR add on shows as “Subscribed”. I can restore the purchase and it says “Restore Successful”. But whenever I go to invoke the AR in Sketchup Viewer on my iPad, I am taken to the “Subscribe” page, not the AR add on itself.

It shows two ‘freemiums’ (SketchUp Free)

Hi, sorry this is still happening for you. Are you signed in on any other mobile devices with this account? It’s possible if you’re signed in to too many other devices (specifically mobile ones) with this same account it’s locking you out of AR because of that and not because of your subscription status.