iOS subscription not activated - AR batch PRO not removed

I’ve installed the sketch viewer on iPhone X - iOS 13, bought the subscription for a year.
Nothing happening, the AR option doesn’t remove the batch PRO and when I open a file it reopens the subscription window over and over. Tried to restore the subscription, nothing changes. I even retried to re-subscribe but it tells me I already have an active subscription.

Anyone has a solution to this issue?

thnx!

Have you tried turning the phone off (and back on)?
Did you ever used a google sigin? Try that.

Thanks for your advise!

I’ve tried both without succes… restarted the phone, logged out of Trimble and back in with google, no changes. restored the purchase didn’t change anything either.
Same issue on the iPad Pro 12.9"

Did you buy in the appstore? (~$10, or so)
Or trying to add your subscription tiered Trimble ID?

Yes, I’ve got it from the App Store.

Strangely, I can’t get AR to not work, even if I sign in with an account that doesn’t have a subscription. I checked my iCloud settings too, I don’t have the subscription for AR.

@Barry I may talk to you about why I can’t fail, but do you also have ideas on why youg can’t succeed?