3D Text broken on export

3dprinting
3dtext
help
solidinspector
faces

#1

Hi there,

Hoping this has a simple answer.

I am creating 3D text to export for 3D printing, and I believe the letter objects are not ‘watertight’ creating a problem with the faces when exported to a slicing program. However I have used a couple of fixing methods and don’t seem to be able to sort it. I have used ‘Solid Inspector2’ but it says there are no errors, and I’ve used MakePrintable to fix the file but it is only half successful. Pix to illustrate. Can anyone point me in the right direction?


#2

Can you post the file so we can take a look at it? Otherwise, we are just guessing…


#3

Sure, my bad, it looked like something that could be visually diagnosed. File attached. Have tried several fonts and it’s happened with all of them. My steps were to make 3d text > explode > extrude letters

Text.skp (209.6 KB)


#4

The issue with the file you posted is that there is no back face.

Because of that, this is not a solid.


#5

Hi Aaron,

Thanks for checking it out. That is indeed not a solid, I admit I rushed finding a file and didn’t check that. However I am seeing the same issue on my other files that do appear to be solid. Would you mind casting you eye over this file? Thank you!

TLS_text.skp (1.1 MB)


#6

If you group the letters at the bottom together and run Solid Inspector2, you get quite a few issues:


#7

Ah! Thank you! I didn’t know you had to group before running the inspector. I have grouped each set and run all the recommended fixes. Sadly on export the text looks no different :crying_cat_face: :


#8

What file type are you exporting and what software are you viewing it in?

I exported a .STL file and pulled it up in MeshLab:


#9

I am exporting it as a .obj and viewing it in software called CADExchanger with which I change it to an .stl

The .obj looks broken (albeit slightly differently) in my Mac preview too.

So are you saying gI can export as .stl straight from SketchUp? This would be ideal for me.

Thanks for sticking with this!


#10

You can export an STL file with the STL Exporter extension on the extension warehouse. Export with a single click!


#11

Well I’ll be damned. That is so much easier and has indeed solved my problem! Must have been something odd going on with the .obj conversion. Thank you so much!


#12

No problem, at all! Happy to help.


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.