2 issues w/ 2D people (photo textures, extra faces)

Hi all.

I like creating my own 2D people but am running into 2 issues. First to set the stage, I am just taking photo images, cutting out the desired figure to isolate the shape and then saving as a PNG with transparency.

Issue 1:

The 2D people come in with the whole image size frame - it shows no color (is transparent) but it is still selectable as a whole single face including the image of the person. So I trace the outline of the person out with the free hand draw tool and exploded the 2D person image, aiming to “cut” out the excess face area so that it could be deleted (once the newly drawn outline and 2D image are merged). But this has not worked. My work around is to hide the “bounding box” edges but would rather just have the image shape.

Issue 2:

This one is quick but frustrating as hell. I save my 2D person and then I import and / or C+V then into my main working file. No photo texture appears and the aforementioned “full face” is grey. In the materials window the file is shown and I have even tried reassigning the root image with no success.

So any help would be wonderful - thanks so much.

I guess I have to reply with image #2 as I am a new user (actually just a new account)

What version of SketchUp are you actually using? Your profile says SketchUp Free (web) and 17. Your screen shots don’t appear to be coming from SketchUp Free. Please correct your profile.

Upload your .skp file so we can see exactly what you’ve created. In the first case it looks like you have an image with transparency but you haven’t removed the transparent pixels. Hard to say exactly without seeing the .skp file.

OK I just kind of solved one issue # 1 - or at least found a work around…If instead of cutting out the 2D photo figure in Photoshop and exporting as a PNG, I can bring in the whole image (import) and use the freehand tool to drawing the out like. This separates the face and I can delete the excess.

However, it would still be preferable to draw the outline in PS because I have more control of detail.

Obviously the root of the issue must lie with the import process or the file type (PNG)

An image will always be rectangular. It doesn’t matter if you’ve made transparent pixels. Obviously drawing the outline in Photoshop won’t create geometry in SketchUp. It’s not the import process where this falls apart. Depending on the version you are actually using, you may be able to use an extension to trim the transparent pixels.

Hi Dave - OK can do. I am running 2017 Pro - sorry mistyped in profile. I will get a file up.

1 Like

2D Photo Coffee Girl.skp (1.3 MB)

Can you share the actual image you imported. You’ve apparently imported it as a texture or imported it as an image, exploded it, and made a group.

I expect we can get it sorted with the actual image instead.

Kinda embarrassed - issue #2 was a stupid mistake on my part - I had accidentally set my scene to shaded so every time I was looking at it, it was coming in as grey. So I just discovered by changing the Style that it is not an issue - it was the setting :blush:

You bet - here is the edited image

I grouped it with the outline I drew originally - I went in there and got rid of that to avoid confusion but didn’t ungroup the image - as you noted.

OK. Howzzat?

I used first cropped out all the unneeded transparent pixels. As I wrote before an image must be a rectangle. There’s no need for more of it than is useful, though. Download this image and look at it in PhotoShop to see how it is cropped.

Then I imported it into SketchUp as an image and LEFT IT AS AN IMAGE then saved the file. I used Image Trimmer which is part of TIG’s SKM Tools to trim away the transparent pixels and leave a face shaped like the non-transparent pixels so it’ll case an appropriate shadow. It also creates a component that could be modified to always faces the camera.

Woman with coffee.skp (431.7 KB)

1 Like

You can do a manual trim if you are happy with a less accurate shadow, the other downside to this is it loses the image property that allows it to stay visible while editing other things.

1 Like

Yep works perfect - I guess the idea being to get it cropped to the image just as you said - basically so it is touching the image on each said (i.e. head top, toe and elbows). Thank you for this helpful fix!

Thank you Box for another approach which I can utilize - I think the shadow trade off is acceptable in that respect. Cheers!

The point of cropping out the excess transparent pixels is to eliminate pixels that won’t need to be processed and speed up the trimming operation.

Ah roger, I see - after playing around with it I am clearer on this aspect. Thank you Sir