Wrong Texture UV passed to external renderer

Hi @SketchUpTeam!

I’ve stumbled over annyoing bug in external renderes which sometimes do not display texture in the same UV orientation/scale as it is displayed in SU viewport.

I first thought it’s external renderer problem (I use Enscape) so I checked with developers but they found out that wrong UV coordinates are passed to the renderer. See [this thread](Incorect UV mapping) in Enscape forum.

Here’s example scene. When applying material to a top level group it renders out differently than it’s displayed in viewport. If I apply material directly to the surface it renders out correctly.

Thanks,
J.
uv_error.zip (175.3 KB)

@DaveR the way I’m using texture on those pictures is deliberate. I made dynamic component for picture frame with the intention that I will be able to quickly swap pictures in the scene as needed. So applying texture directly to the face is not an option because this way I have to make each picture frame unique.

For swapping image textures, my recommendation is to instead, just ‘Edit’ the texture and path to a new image file. That way you can avoid dynamic components and the UV mapping misalignment.

See example:

Thanks but, I’m not looking for a workaround… I’m a long time Sketchup user and rest assured I am aware of all the things you suggested above. I’m not going to go into details why your suggested workaround is not solution for my needs because the bottom line is there’s a bug in API that passes wrong UV coordinates to external renderers. This picture frame is just an example I had handy, it happens in all sort of situations where sometimes workarounds can not be used.