Why this happens? Intended or bug?

I was just adjusting some old walls in my 2D plan, when I tried to delete unecessary lines and the face of the floor disapeared. I tried some other lines and same happened, one another deleted the internal face of another wall. Why this happen? Is it a bug or it is intended to work that way and I am missing something?

I can circunvent that by just selecting the end of the wall and pushing it to merge with the other, but I really would like to understand what is happening here.

I am linking a video. Sorry for no audio feedback, my PC is old and have no MICrophone. But you can see me trying what I just described above.

Thank you

VIDEO

This isn’t a bug, at least not a bug in SketchUp. The edges you deleted clearly were required to support the face. In order to have a face there must be a closed loop of co-planar edges. You cannot delete one of those edges without losing the face. You could hide an edge if you don’t want to see it, though.

1 Like

But then If I just retract the wall to inside another, the same should occur? That geometry that is required to support the face is no longer available BUT the face does not goes away.
Please check my video.
PS: I even try to delete all 3 geometries at same time.
VIDEO

Upload the .skp file. It looks your removal of those edges is resulting in a face reversal.

I don’t think is face reversal because once it changed color that was my first thought, I tried to face reversal to realise there was no face at all.
I realised meanwhileI skrewed at somepoint and this big mistake may be associated with my complaing in first place, I guess it was my fault after all.

I hate Re-Work :exploding_head: :confounded:
Thank you a lot for your attention anyway.
casa bady V57.skp (531.0 KB)

I suspect bow tie loops where faces exist in the same location with using (some of) the same edges.
Itś the way you draw the wall loops in the floor plan.

1 Like

Somehow SketchUp has gotten confused about the geometry in your model. In this animation, I show that it isn’t possible to select the face that ought to be contained by the offending section of wall. I confirmed that the corners are coplanar and in the same plane as the larger face, so that isn’t the issue. But if I redraw it using the rectangle tool, the problem is healed and the section can be deleted without losing the larger face.

bad_faces

So yes, this would seem to be a bug, or at least unintended behavior. @Wo3Dan may be right that it is an instance of the long-standing “bow-tie bug” that results sometimes when you draw a face inset in another where its boundary touches the boundary of the larger face in certain ways.

2 Likes

Most often (always?) when the new drawn inner perimeter touches the outer perimeter with only one vertex.

2 Likes

Thanks, I guess thats the “closure” of the mater.