WebDialog doesn't display images

Hi there! I have a new problem: I’m using a WebDialog to display a webpage, however on Windows the images weren’t able to load. Does anyone know of a workaround?

Here’s a screenshot: https://drive.google.com/file/d/0Bx-NYabPCE8VWUhQcDdSMzFHbGc/view?usp=sharing
Website is bimandco.com

Can you share a small snippet reproducing this?

Also, what SketchUp version and OS are you using? (What version of IE/Safari do you have installed?)

On Windows you can just drag and drop image file(s) into the forum post edit box.

(Moving to the Ruby API category.)


Testing the landing page for:

The images load fine in MSIE v11 outside of SketchUp.

They load fine inside a SketchUp webdialog in SketchUp 2016, with browser emulation set to IE9, Win7 (with latest v11 installed and updated.) But your page can override that setting.

d = UI::WebDialog::new("Test")
d.set_url( "https://www.bimandco.com/en" )
d.show

Using SketchUp Pro 2016 and Windows 8 (Fully updated with the latest updates). Not sure which version of IE it uses though. Most of the images work fine but the main photo section for an object seems broken (As seen here for reference: https://www.bimandco.com/en/bimobjects/3480). They do work in vanilla IE (But once again, not sure which version it is)

Tested on Mac and right now on Windows 10, images do load.

I will ask the website designer for a way to override the browser emulation default, that might solve the problem. I don’t want to break Mac or other Windows support though…

Hm… maybe this is an IE compatibility thing. When IE is embedded into a web view its put into an older compatibility mode than when in the browser. Normally you have to add a tag to force it to use the latest <meta http-equiv="X-UA-Compatible" content="IE=edge"/>

And I could have understood if it was SVG files not being loaded. But it appear to be PNGs? That along with Dan indicating that an older IE mode (9) worked… strange.

I had included a link to another topic thread that discussed how SketchUp uses the current MSIE libraries …

Basically SketchUp puts a default emulation version at registry key:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION

Ref: https://msdn.microsoft.com/en-us/library/ee330730(v=vs.85).aspx#browser_emulation

I speculated that:

But I noted (in that thread) this is likely set so as to allow Trimble Extension Warehouse and the 3D Warehouse to work.

So, I don’t think they should be changed unless the SketchUp team asks us to.

I also said, in that thread, that it is best to override this using the <meta> tag, (as Thomas also says in his reply above.)

I included web links to good information about MSIE document compatibility.
(I post them again for your web designer.)


It is traditional in Windows software, that there be an “About <software name>” link at the bottom of the “Help” menu, that opens an “About” dialog, that displays (in addition to copyright statements,) the version of the software.

Microsoft Internet Explorer continues this tradition.

For example, on my machine, the MSIE “About” dialog displays:

Version: 11.0.9600.18349
Update Versions: 11.0.32 (KB3160005)

Most of us have never seen your website before, so “main photo section” meant nothing to me.

Okay, now YES I can see there is a big box labeled “Official”, and within it a left column of tabs, and an image broswer frame of some kind, accessed via the tab “Photos”.

Within SketchUp, the photos inside the image browser are little [X] symbols. Like the page cannot access the image resources.

These images are coming from another domain it looks like:
https://d2gs61btqzt6ta.cloudfront.net/photos/

Why use “https://” protocol ?


Also in the head, I see:

<!-- HTML5 Shim and Respond.js IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
            <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script>
            <script src="https://oss.maxcdn.com/libs/respond.js/1.4.2/respond.min.js"></script>
        <![endif]-->

… and many references to a “role” attribute in the HTML elements.
These pages are aimed at HTML 5.


And BTW, in American English we do not normally use the term “Informations” spelled with an “s” on the end, in a plural sense. It sounds weird that way.

The word “Information” is a word describing a collection or set. Ie,
http://www.webster-dictionary.org/definition/Information

  1. Any fact or set of facts, …

Manually changing the registry browser emulation for SketchUp.exe up to 2AF9 (11001) does not directly help.

The image browser on that page is still broken.

I suspect it is a security issue.


OK, I am able to get the images to load, sometimes after refreshing the page several times.

d = UI::WebDialog::new("Test",200,100,1000,800)
d.set_url( "https://www.bimandco.com/en/bimobjects/3480" )
d.allow_actions_from_host("bimandco.com")
d.allow_actions_from_host("d2gs61btqzt6ta.cloudfront.net")
d.show

OK good to know. I’ll just warn the people who made the site so that they can troubleshoot that.

Correct, users should not change this. Developers should use the META tag to control the compatibility mode of their webdialog content. Otherwise it might break a number of things in SketchUp.

1 Like