Using angle tool to set a slanted cylinder

I need to set a cylinder at an angle upward from the horizontal, but when I do so, using the angle tool, the cylinder also takes a slant off the horizontal direction ie: it moves in two directions as I try to slant it in just the vertical. What’s happening here, and how do I avoid that?

It’s slightly hard to visualize what you’re describing, but, if you want the base and the top of the cylinder to still be horizontal, and the top to be off to the side, select the top and then use the Move tool to move it to the side. Hold down the auto fold modifier key (shown at the bottom of the window) to let it create the new geometry needed to move the top off to the side.

No. I’ll try to do a better job of describing the problem. I have drawn a circle centred at thevertex of the 3 axis, then used the push-pull tool to create a cylinder. Viewed from, say, the right side the cylinder is horizonal, parallel with the green axis… Viewed from the top it is also parallel with that green axis. Again, viewed from the side, I select the entire cylinder, then use the rotate tool to angle the cylinder upward, pivoting from the centre of one end. So far, so good. But, viewing from the top again, the cylinder is now also rotated slightly off the green axis, to which it was parallel before. This is the problem.

It sounds like you are getting the rotation point just off axis.
Here you can see I click and drag to set the rotation to the red axis.
Click drag and release to set it then click and release to begin the rotation and a final click and release to end the rotation.

Thanks for the demo. I’ll try to do it that way. Right now, the only way I can get what I want is to draw the circle in front view, switch to side view and angle the circle to the slant I want, then use the push-pull tool to form the tube. That works.

You could also tap the Right arrow key to set the axis of rotation to the red (X) axis after selecting the Rotate tool. (Or a different arrow key for a different axis - Up for blue, Left for green)

No. Doesn’t work for me. Seems like my Sketchup is not working like your’s or Box’s Sketchup. I cannot, for the life of me, get the rotation tool to work like that. When I look at the tube from a perspective view and try to pick the centre of the tube as the origin of the plane of rotation, the rotation point will only align with the face of the tube end. Any attempt to change it to align with any other direction fails. Picking a different axis with the arrow keys, as you suggest, has no affect at all; the protractor image stubbornly refuses to align in any other way than concentric with the tube end. Frustrating. What’s going on here? I’m using Sketchup 2015 installed on a Linux machine with the software installed as a wine application. Could that be a problem?

Yes, john’s advice only works on 2016 and higher.

You’ll need to use the click+drag method of specifying the rotational axis.
You click+hold the origin (which is the center of your tube’s bottom face,) and while holding the pick button down, drag along the red axis until you see the protractor turn red and align it’s normal with the red axis, then release the pick button.

Because you’re in a virtual environment, you’ll need to likely allow more time for mouse inferences, and tool states to activate.

Ah, ha! Thankyou. That works at last. This thing was deriving me crazy!

Sorry, I forgot to check which version of SU you are using. As Dan says, the method I suggested works only in SU 2016 and later.

Glad you got it to work! Going back to your original attempts, here’s what may have been the source of your struggles:

In SketchUp, circles are actually represented as many-sided polygons. When you drew the starting circle, it is almost certain that none of these sides was oriented in the vertical, blue axis. For example, if you start the circle on the red axis, SketchUp will put the first vertex on red axis and draw the first edge as a chord to the true circle - which puts it at a slight angle toward the blue axis. Then when you pushpull the circle to a cylinder, the side of the cylinder is actually a many-faceted surface, one face for each side of the original circle. You can see the facets if you turn on View->Hidden Geometry. And, like the edges, none of the facets are parallel to the blue axis.

Now, when you activate the rotate tool, it tries to lock onto one of the facets unless you use one of the techniques provided above. That will put the rotation off axis because the face is off axis. In the animation below you will see that the rotation cursor is black, which indicates it is not aligned with any axis. Rotation about that skewed direction will cause what you described.

1 Like

Yes, I spotted that early on, though I couldn’t have described it as clearly as you did. What I did was pick the centre of the front circle with the rotation tool and the opposite end as the second, making sure I got the centre at that end by turning on x-ray view and seeing that I got it. This didn’t work, I guess because of the effect you point out.