Turn extension(s) off by default

Hi All,

Is there a way to have some extentions turned off by default? I have a extension which i use to render but, it’s starts up by default which takes up a minute or so, which is verry enoying especially when switching al lot between sketchup files.

I tried the search (also google) but, i can’t find the answer.

Thnx in advance!

There are several ways, two are
Use the Extension manager to disable the relevant extension
Install the Sketchucation tool which allows you to turn extensions on and off

This sounds like a malfunctioning extension. No extension should take minutes to do anything unless you tell it to do something. I’d contact the extension authors.

Yes, Extensions > Extension Manager

Then click the switch to disable the render extension.

Lastly … Restart SketchUp

Thanks for your help!

Option one works but, this is simply always on or always off i was hoping for an option where it’s off by default so even if i had turned it on it will be off next time.

I will check Sketchucation tool though!

I thought that this was normal as it’s a render extention.
I have had the same issue with SU Podium (now working with Unicorn).

Thanks for your reply man!
Not exactly what im looking for, i’m looking for a kind of toggle i guess which kan turn on the extention only once and wiil be off next time…

You can do this if you are familiar with the Ruby API.

If you change the "Extension Name" to the proper name (2 places below,) then this script will add a menu item that you can assign a shortcut to …

UI.menu("Extensions").add_item('Session Load "Extension Name"') {
  ext = Sketchup.extensions["Extension Name"]
  if !ext.loaded? && Sketchup::require(ext.instance_variable_get(:@path))
    ext.instance_variable_set(:@loaded, true)

Wow that sounds great. Not familiar with the Ruby api but, i will give it a try tomorrow!

Thanks again man!

1 Like

This shouldn’t be normal for a render extension, unless you have clicked Render.

I’ve installed several render extensions to test them. They have all noticeably extended SketchUp’s startup cycle. Not minutes, but certainly in the range of 20 … 30 seconds.