Trackpad zoom

I want a way to disable the zoom function from the trackpad and/or the mouse. It is nothing but an annoyance that wastes copious quantities of time (regardless of how many opportunities it provides me to practice my chops in post-blasphemous cursing).

The only way I want to effect zooming is by pressing a specific zoom button (the magnifying glass), and the only way I want to zoom-out is either by a zoom out button or a modifier key, like control, and the magnifying glass button. The current zoom set up keeps producing unintended and unwanted zoom actions. It is so annoying and obnoxious to me that it is a show stopper as regard model building…it make the entire modeling package useless to me. A simple enable/disable menu function would solve the problem for those, who like me, absolutely hate the current set-up.Alternatively, assign a key to be pushed the enables trackpad zooming only while the key is held down. Please! Give users the option of making this time-wasting, annoying and utterly obnoxious feature go away. Until it does, I’m going back to Bryce 7.1 for all of the precision modeling tasks I have, importing the models into Sketch-up when a model is complete.

I understand those who like the current set-up, and am glad it works for you. For me, however, it’s a show-stopper: Annoyance, frustration, wasted time, disruption of concentration, and anger should not be an integral part of the user’s experience.

No replies are necessary.

What version of Sketchup are you using? Your profile says version 25 but there is no such version.
Screenshot - 7_21_2023 , 10_23_21 AM

My guess is that something like 87,3% of SketchUp users don’t use the Zoom tools but only use the wheel and middle button of a mouse to zoom and pan. Most laptops have a special key to disable or enable the trackpad in one click.


Sorry about that…mis-typed. V 22.0.353. My bad.

The problem is that if I am using the track pad, which is quite useful for other tasks, the zoom function keeps getting triggered accidentally. I am unaware of an disable function of my Mac, Ventura OS, V 13.3.1(a). If you know how to do that, could you share that with me?

Thanks for responding.

Did you know that 72.1938% of all statistics are made up on the spot :rofl:


Not at my Mac now, but I think you can configure gestures. Not sure whether you can do it per app though.


Thanks for your response. Sorry my request for a modification offended you. But, had I not cared, I would never have submitted the request. This looks like a great program, but it has a few features that really drive me up the wall. This particular function could, alternatively, be made to be assignable to other functions, with the pan tool being the most useful for the way I go about constructing models.

Where this gets annoying is when I am working at a certain level of magnification, getting sub-objects lined up for grouping into larger assemblies, and I accidentally trigger the zoom feature by inadvertently touching the track pad incorrectly, producing a zoom, which does not seem to respond to an undo command. Then, Time is wasted trying to get back to exactly where I was. I don’t know about you, but when I’m completely focused on building, something like this disrupts focused concentration, which disrupts momentum. When this happens every few minutes or so, it rapidly becomes insufferably annoying. Thus far, I have failed at training my hands not to do this, and mindful practice does not seem to improve my sills in that regard. I have Multiple Sclerosis, and that screws around with and degrades both coarse and fine motor control skills, meaning I will likely not be able to overcome this obstacle. But that’s my problem to deal with and find a work-around I can come up with. In the meantime, I really hate the disruptions and interruptions that this feature brings with it.

Thanks again for responding, have a nice day,

Paul (knob)

Did you know that 27.8062% of all statistics are backed up by evaluated data?

By the way, @Anssi meant 88,3% of SketchUp users, not 87,3%.

Man what a waste of time, this thread. I’m out.


Thanks. This is news to me. I no that the i-phone can configure gestures. will look into this. Thanks for your reply!

Absolutely. Mine was, of course. I forgot to invent more decimals to make it scientific.

It’s an age-old rhetorical device invented by American advertisers.

I absolutely love real statistics. When I use them I post a link or mention the source.

1 Like

The time I had a Mac laptop it had a trackball and trackpads had not yet been invented. Sorry. On my Windows laptops I have never seriously tried to use the trackpad for SketchUp or anything else. Currently I have it disabled altogether. They just aren’t a thing for me.

1 Like

Statistics say that about 44 % of marriages in end divorce, which means that 56% of marriages end in death.

I’ll do non-linear differentials when I must. I’ll do fractional dimensional geometry 'til the cows come home. I’ll even do statistics, if I can’t avoid doing so. But graphing is where I draw the line.

Wow…tough audience.


@colin knows the mac trackpad backwards.


Is that the dapkcart caM?

1 Like

I see what you did. You’re a good person.

You can turn the pinch to zoom gesture on and off in System Settings->Trackpad->Scroll & Zoom. As I suspected, it is across the entire OS, not per app.

Fix it please.

I’m working on knowing it forwards as too.

I believe that disabling mouse wheel gestures at the system level may solve the problem, but it would also stop you from being able to scroll through your components list. But, I don’t see a way in the system to disable the two finger scroll anyway.

One thing that could be done is to apply the web version settings to the desktop version. Then, an accidental two finger scroll might just orbit a little, or pan a little, and two finger panning might even be desirable.

Here’s the other settings for trackpad in the web version:

@Mark may have thoughts on this as well.

Hi Paul, SketchUp is really designed to be used with a 3 button mouse…
Maybe your MS is getting in the way using a mouse, I don’t know.
But else you should give that a try!
The scoll wheel is for zooming in and out. Pushing the scroll wheel and moving the mouse is orbit. Pushing the scroll wheel and shift at the same time and moving the mouse is pan…
Good luck with this ordeal.