Tangent inferencing not working


#1

Hello all,

Ive recently started having an issue where my lines will not ‘snap’ (to use an incorrect term) to their respective 90 degree angle or tangent curve.

Example the first. I have a square plane .75" x .75". I use the 2 point arc tool from corner to corner. It will not snap to the correct tangent. All that will snap is the midpoint of the square, leaving the arc proud of the square plane.

Example the second. I have a rectangle plane .75" x 12". I use the line tool to add a 45 degree chamfer. I click in the corner and again, it will not snap to the correct position for the 45.

I have to use the tape tool to manually go over the .75 then draw the line. The arc tool is similar.

This is a recent development. Ive never had issues with snapping. Ive updated to the most recent version of SU and the issue persists. Maybe I changed a setting somewhere…

Thanks in advance for your response.


#2

the dimensions seem rather small. Have you tried with a larger rectangle?


#3

Did you check your snap settings?
I just tried same sizes and had no issues snapping with these settings:

Window > Model Info to access


#4

If I understand correctly, the problem isn’t with size, it is that you are trying to draw the tangent arc using the two opposite corners of the square. The tool wants the two endpoints to be somewhere within the edges, not at their ends. It will work if you draw it to a point along each side even though the arc is smaller, and will work if you add extensions and draw to points along those edges, but won’t work when you draw exactly to the corners. This was the same in SU 2016. One could argue that it doesn’t make sense, but I think the implementers decided there is no meaningful idea of “tangent” when there is nothing beyond the point to which to be tangent.