Solid Tools Subtract Unexpected Result

Hello,

I have a terrain mesh (solid) and another solid (red). I want to subtract the red shape away from the terrain such that I can place a set of stairs and patios etc on the terrain (already modelled).

However, when I subtract, it gives an unexpected result where nothing seems to have happened:

I have tried draping the top face of the red solid and intersecting the shapes instead to then just hide the resulting area however this isnt selectable either.

Any help would be greatly appreciated, thanks!

Share the .skp file so we can see what you are working with.

What version of SketchUp are you using? SketchUp 2024 has not yet been released.

How large and what spacing is the mesh? This sounds like maybe a small faces issue?

That’s one of my guesses, too. Seeing the file would make it easy to figure out the exact reason.

Hi Dave,

Apologies yes I am using 2023, my mistake! Tinkered around a bit changing the red solid and now the terrain mesh is coming up as no longer being a solid, which I suspect is actually the case annoyingly.

Is there any easy way to add a skirt, I must’ve messed up somewhere with this mesh!

Edit: Intersect or drape still doesn’t help me out. Please find the skp.
Terrain.skp (2.4 MB)

The top terrain is 2266m^2 roughly. Small faces would make sense, it has come from a surveyed point cloud.

An easy way to add a skirt would be to use Topo Shaper to generate the terrain from the point cloud.

The tiny faces thing is very probable. Why are there all these circles on the terrain?


How did you create the point cloud?

I’m not sure why they’re there to be honest. I used point gadget v2 and a csv to generate the points. I then used Topo Shaper to make the mesh but the skirt option didn’t seem to work.

I have used the predecessor to point gadget v2 and never had these circles appear on the mesh before when using Topo Shaper but with this they did? I assume it’s been draped from the cones it creates?

Looking at the unextruded version of the terrain, the surface is full of holes! In the image below I set the background color to a purple shade to make these more evident. Most of them are circles, but there are also some other gaps. You will need to fix these before the version with the skirt will be a solid.

I would use a different importer to import the CSV as a point cloud so you get guidepoints instead of circles. Then use Topo Shaper to generate the terrain from the cloud.

Oh thank you so much! I didn’t notice at all! I thought it was just odd draped circles from point gadget v2. That is very helpful!

Are there any you would suggest? The predecessor used to use guidepoints but this seems to use the cones. I couldn’t find a download of what came before annoyingly.

Edit: Would just putting a guidepoint into the cone componant work for Topo Shaper?

Cloud from Sketchucation should work.

If you put in a vertical edge and delete everything else in the component you can also use the native Sandbox from Contours tool.

Looking at the cones more closely I see there’s a guidepoint already at the vertext of the cone. Edit the cone component and delete the cone leaving the guidepoint and then explode all the cone components leaving them in the group. TopoShaper will then work on them.

Thanks Dave, coming back to this project after a month away. Topo Shaper returns errors saying that the selection cannot use guidepoints which is what got me to the mesh before hand. Would I perhaps be able to use Enroth make faces or similar to quickly patch it up?

Hi Ansii, have just tried this. I didn’t know the contours tool could work from points and triangulate?

Which option did you use? I ran Topo Shaper on the point cloud after deleting the cones as I wrote and it worked fine. I copied it to a new file just to simplify things and it worked fine again.

It doesn’t work from points but it can use any geometry. It doesn’t require continuous contours. I once had AutoCad survey files with point elevations marked with text. I wrote an AutoLisp macro that added a vertical line to every text element, with length derived from its content. When imported into SketchUp the contours tool could be used to fit a surface over them. It only used the top endpoints and ignored the bottom.

Apologies, I misread it. It says it does not contain guidepoints.I am using the Trimesh terrain option. Have tried the points both in and out of a group and in a new sketchup file.