Solid or not solid


#1

I have tried to use Sketchup for 3d printing but it seems that it is only good for simple shapes -like a box. 3d text seems to be a bit of a failure.
Whatever I do I cannot make 3d text into a solid required for all 3d slicers.
What Sketchup needs is a MAKE SOLID button.

Pity,

John


#2

Not true.

Show us an example of what you think should be a solid and in fact isn’t?

3D text creates solid components. When the component consists of more than one character, the component is still a solid, i.e. all the separate shapes inside the componentr meet all SketchUp’s requirements to obtain a solid component: all shapes are closed, their edges bound only two faces on “either” side of each edge. And there are no stray edges in the component.
It’s up to the/a plugin to convert this solid into a printable single shape.
You could also make a connection (intersect with a corridor) between all separate shapes to thus create a single shape that is a solid. Use the solid tools to do so. Or with some extra effort you could still do so with the native tools in SketchUp Make.


#3

As Wo3Dan suggest - if you can share some example of what you are describing it’d help us help you.
It’s possible to make 3d printable objects - but SketchUp isn’t a solid modeller so it doesn’t enforce manifolds at all times. So the user needs to take some extra care to ensure this.

I have however written an extension to assist in determining such problems, maybe that will help you as well:
http://extensions.sketchup.com/content/solid-inspector²


#4

Extruded 3D Text is automatically a SketchUp Solid Component.



Can you explain what you’re doing?
Better still, share a model like @Wo3Dan suggested.


#5

Hi,

Loaded extension and just get Oops Error!

John


#6

TestM.skp (1.1 MB)
Looks like a good tool for geometric stuff but try unravelling this!
I tried for about 1 hour and gave up…
John


#7

Thomthoms tool fixed it in two clicks.
But I also removed the overlap which also took a couple of clicks.
You had loose geometry floating about, not to mention 26 other components still in the model.
Scale up to work on small stuff and down when you have finished.
There is nothing saying this letter will now print, it depends on the printer and the relevant software, wall thickness etc.

It’s a bit of a giveaway that the bounding box is so much bigger than the letter. There has to be something there.


TestMSolid.skp (36.5 KB)


#8

See if this one 3D-TestM-Wo3Dan.skp (44.4 KB) prints


#9

I’d appreciate if you’d post the error message which the dialog present as well as a test model where it happens.

I tried the TestM.skp model you attached and I did not manage to reproduce errors.

Btw, it appear that the font you used to create the 3d text has some overlapping paths. That kind of stuff needs to be cleaned up.

Intersect the model with itself and remove the geometry that lies on the inside of the manifold.

Other fonts with cleaner outlines will be easier to work it.


#10

The component definition is M m but the 3D Text is just M thus it appears you edited the component.
In doing so you left behind 8 stray edges, 3 of which were hidden edges.
Click … View > Hidden Geometry


#11

George,

Sketchup is not as easy as SCAD but the only thing missing from SCAD are 3d letters.(which is why I used Sketchup)

I spent another hour trying to fix the Mm on a flat base. I got one m fixed by going back to the back outline. However, getting the other one fixed seems really difficult as everything I try to move or erase has a really distorting effect on the rest.

I will spend another hour trying to understand what is happening before going back to scad and creating characters by hand.

You would think that ‘3d text’ would be solid? However, some of them are not.

I can see from the solid inspector where the problem is but trying to just grab an edge to close a space seems beyond me at the moment.

Thanks for the pointers though and the solid inspector tool.

John


#12

Hi there Experts!

I started to use SketchUp mid-summer last year for a simple project and this year I am using it for something slightly more complicated and really appreciate your inputs/insights on what’s the best approach to solve my solid problems going forward.

I am trying to 3d print a board with some holes in it, as shown in the picture below. It took me a while to understand I must drill hole by editing a component if I had made the component before thinking of drilling holes. At any rate, I think I was able to edit the board as a component and drilled holes.

I started drawing the board in the correct upward position. And the picture below is up-side-down to illustrate my problem.

Now that I have drawn the board, but the bottom portion has no surface at all - hence it doesn’t make this a solid. Question is - what should I do to fix this problem? I viewed a few YouTubes and kind of understand a solid should have no seams, stuff like that. I really like to hear your guidance and suggestions. What should I do with the drawing as it stands right now? Would you please point me to the right direction?

Sincerely,
Student_T


#13

Sometimes SketchUp isn’t sure what you were trying to do (or just goofs) and doesn’t close a surface Face. In these situations if you redraw any Edge of the surface, SketchUp will get the hint and create a Face. If it does not do so, it means there are gaps in the outline or other flaws such as non-coplanar Edges that make it impossible to create a Face.

If you want more detailed and specific help, please post your model here so that the experts can look at what is going on. A picture never tells the whole story!


#14

Thanks for your immediate response. I am attaching my skp file below and appreciate your inputs!

C_x_direction_baseboard.skp (1.4 MB)


#15

I’d guess scale could be a problem also, if it is very small SU may not want to create the face.
One of the simplest ways to sort out any issues with something like this if redrawing a line doesn’t work, is to just use the face and create a new component.
Double click to enter the component, click the face once to select, ctrl+c to copy, click outside to close the component, ctrl+v to paste, p to pushpull, triple click to select all, right click make component, Done.


#16

Hi Box - You have made it so simple! Thank you so very much!
Sincerely,
-Student_T


#17

As a further note, the technique Box illustrated is usually the best way to create a shape that can be handled as an extrusion: draw one surface first, complete with interior holes. Then push/pull it to the required thickness. This way is much less likely to create errors than creating a rectangular solid and then drilling and cutting holes and notches in it.


#18

Sigh - sorry for the newbie follow-up questions. I tried applying the “pull surface” step and was happily moving forward to convert some of the drawings to 3d solids. But after I discovered that ThomThom’s inspector told me I’ve got “nested instances” and the volume doesn’t show up any more, I think I’ve got more issues. He said the object will export to STL correctly so I just like to clarify whether there are ways to get them fixed.

I have enclosed a simplified model, where there are just two shapes I wanted to union. But I can’t get the union-ed due to they are not solids. Could you please provide a little more guidance? Here’s the model: solid_questions.skp (1.1 MB)

Thank you so very much!
-student_t


#19

https://www.screenr.com/BauN


#20

In the interest of education, I’ve been pondering how you might have created the model to get those errors in the first place and how you could avoid them in the future instead of having to fix it afterward.

The puzzle isn’t how come the thickness of the “C” and the “bar” don’t match. It’s easy to speculate why. Most likely, when you push/pulled the second one you either didn’t double-click to match the first push/pull, or you didn’t hover the cursor over an edge of the first object to tell SketchUp’s inference engine that you want to match it. A non-constrained push/pull got close but not quite.

What isn’t obvious is why the little face between the bottom edge of the bar and the top edge of the C is missing. Push/pull would normally have created that face. Did you delete it hoping to get rid of an “internal face” that was keeping SketchUp from considering the object to be solid? Or did you draw the object in some way other than push/pull?

Finally, because you push/pulled the two parts independently, SketchUp created a face to close the surface of the first one, and that face remains as an internal when you push/pull the second. To avoid this, you can draw the two shapes in the same plane, erase the edge between them, and then push/pull the resulting single face in one go: