Sketchup Pro refuses to open browser login page


I cannot log into Sketchup Pro. I see that lots of people have login problems, but I think I have a new variant for you. When I click on the “Sign In” button in the program, it opens a web page which is almost blank, except for the text:

“W00T Logout is done.”

Does anyone know what might be causing that?

I’ve tried resetting my password and that says that it worked, so the system definitely knows me, but I cannot sign in to the program itself.

Thanks for any help!


1 Like

It’s actually an expression of succes:

Try if deleting the webcache folder helps of SketchUp:
Stop SketchUp, delete the Webcache folder in this location:
%AppData%/SketchUp/SketchUp 2021/SketchUp
Change the standard browser in your system
Or delete all caches related to trimble.
Start SketchUp and sign in.

Thank you for your reply.

You are right! The problem does appear to be a result of the browser that I use (Firefox). If I temporarily swap to having Chrome as the default browser, Sketchup starts and allows me to login. I do get infrequent but regular error message boxes appearing saying: “cannot access skp.0”, but they don’t seem to have any bad side-effects. So I, hope that I can ignore those. :slight_smile:

It would be nice for Trimble to use more friendly warnings, though, e.g. “We require you to have Chrome as your browser”, or some such. Even better, a way to tell it where to find the browser that it should auto-launch to login.

1 Like