SketchUp desktop

Hi, we are an adult educaton centre that runs short courses for adults and young people.
We are looking at Sketchup for the Web Free initialy for 5 people.

We get the blue Spinning SketchUp logo on the web browser and it will not move on.
After a bit of firewall tinkering and policy testing, I found that SketchUp web seems to want to download some compressed files - shares:1

We block access to zip files on our servers across the site for security reasons. is there any way around this at all please.
I cant allow Zip files on the firewall, but would like to use SketchUp.

Is there a desktop version that I could install on 10 to 15 computers that our students could use.
The students would vary quite often as these are short courses.

Many thanks

This is a question for Education Customer Support, the link I gave you in your previous thread. This forum is covered primarily by other SketchUp users.

I tried the education support, but when I clicked submit I kept getting:

The website encountered an unexpected error. Please try again later.

Well, if the websites is currently broken…
@CaseyG deals with that over here.
Not sure when they’ll come next (this time zone thing makes it hard, at times, to know that), could be a matter of hours or a day or two.

I sent from an off the network PC and it sent fine. Must be another firewall setting for the Sketchup site I need to look into.

Hi @trevstanford and thanks for the post. Our team is currently gearing up for Trimble Dimensions in Las Vegas but I’ll do my best to track down an expert and see if I can find an answer for you. I can however confirm that the site is up and working as of a few minutes ago so you are correct that it is a firewall issue.

If you end up needing the desktop version we can see if we can get you educational license pricing if you need the current version of SketchUp but I can’t promise anything without reviewing some details with you first. Alternatively, the old free desktop version is still out there on the internet if you google it and should still work just fine on current operating systems, although it is not officially supported anymore.

This was the response from the support line:

Following your request, I would like to inform you that technical support is for clients who pay their subscriptions annually.

To learn more, please visit this page:

However, for any assistance regarding educational licenses, I will recommend you visit the SketchUp for school forum and to talk to a reseller about your project.
You can direct your questions to the SketchUp For Schools Community forum for assistance at :
SketchUp for Schools - SketchUp Community.

Which contact link did you use? Did you try the Contact Education link?


yes I used the link you sent me to complete the form to message them.


Hi again @trevstanford. Sorry about the delay. Most of our team is out of the office at the moment to support Trimble Dimensions but I am still doing my best to find out if we have a solution for you that will allow users to access the web version of SketchUp.

Also, if you end up needing the desktop version, you are either going to need to use the old version or purchase a license.

Hi, an update:
We have purchased some licences and installed them on our computers,
Set up the firewall for the following:

  • Ports 5053 and 50530 must be open.
  • IPs,,, and cannot be blocked.

yesterday it worked fine and I could run the program and see the number of activations
today, all I am getting on all machines is :
SketchUp Pro is unable to connect to the network license server.

Please read this article on how to troubleshoot the issue.

trying to troubleshoot now !!

This is a public forum. Are you aware of it? I don’t think it’s a good idea to post your public IP address and show which ports are open…
(It’s like leaving your car door open in the wrong neighbourhood…)

Hi, these are the ports and IPs sketchup list as required for the install.
on this link
Managing a Network License | SketchUp Help

1 Like

Hi @trevstanford, thanks for the post and so sorry to hear that you are having difficulty with your license. I’ll ping the servers and make sure that they are working and start talking to the team to see if we have any solutions that we can try to get you up and running as soon as possible.

I’ll edit this post as soon as I have the server ping finished.

EDIT: I have pinged the servers and they report that all is well. I also opened up a copy of SketchUp on my Macbook to make sure that it was not a false positive and all seemed well there too. This seems to tell me that the problem is somewhere on your end. I’ll ask the team if there are any tests we can run to try and start narrowing down the cause.

Hi again @trevstanford. I ran a few additional tests this morning using a Windows machine and they all came back looking good so I am not sure where the issue with your license is coming from. I am happy to try and assist you on this but in order to do that I’ll need some additional info from you and maybe a screenshot or two.

Can you let me know if you are still experiencing any issues with your license?