Sketchup 2023 Bug: Model environment is not taking up the entire viewport, and cursor is misaligned with target coordinates

Sketchup version: Sketchup Studio 2023
GPU: Geforce GTX 1080 8GB
OS: Windows 10 Pro
Note: my Windows 11 Pro machine does not have this problem.

Problem or Bug:
Just as the subject says: (Part 1) Model environment is not taking up the entire viewport, and (Part 2) cursor is misaligned with target coordinates.

Edit: Workaround discovered:

Part 1
Specifically, the top 20% and right 20% bands of the viewport are not showing the model, axes, ground plane, etc. It looks similar to (but not the same as) model clipping such as when zooming into a very small object, except the “empty” or clipped space is permanently static in the above-mentioned area of the viewport. To me, it seems like the entire view is scaled down to the bottom-left to about 80%.

Here, you can see the ground plane and both horizontal axes all stop abruptly about 80% of the way to the right of the viewport, while the sky background and z-axis also stop abruptly about 80% of the way up the viewport.

I’ve observed that when changing the background colour, the “empty” space also changes to match. But the clipping of the model environment, axes ground plan all remain missing in those two bands.

Part 2
My cursor position on screen doesn’t seem to select or interact with the corresponding point in the viewport directly at the cursor. When I click to select something, it won’t select the object where my cursor is. I have to move my cursor a certain distance north (relative to screen space, not model space) of the object to select it.

Example 1. Selecting objects is not straight forward:
I try to click on the object to select it - notice the position of the cursor and having already clicked - object is not selected:

Move the mouse a certain distance above the object and click - object is now selected (also works by moving the cursor the same distance up as the size of the object on the screen):

Move the cursor slightly lower, clicking will deselect the object as if I’m clicking on empty space:

Now, when I choose rectangle or line tool to create something, the preview of the tool’s starting point is nowhere near my cursor. Then when I click to commence the tool’s action, the starting point of the rectangle then moves to a point south (again, screen space) of my cursor. Then when I click again to finish the rectangle, the final point moves again, relative to the cursor position.

Example 2. Creating a rectangle at some random empty space:
Before I click to commence drawing a rectangle:

After I click to commence drawing a rectangle (cursor has not moved):

After I complete the rectangle tool:

Example 3. Trying to create a rectangle by making the starting point somewhere on the existing object (you can see that it is object snapping to a vertex on the object):
Before I click to commence drawing a rectangle:

After I click to commence drawing a rectangle (cursor has not moved, but starting point of rectangle is no longer on the object):

After I complete the rectangle tool:

It is similarly frustrating when trying to window-select objects.

This cursor misalignment problem appears to be (though I’m not sure) related to the Part 1 where the model is not shown in the top & right 20% of the viewport, as I suspect the viewport isn’t showing the model properly because it is perhaps scaling the model view down to the bottom-left 80% part of the viewport, while cursor coordinates appear to be affected differently to the view scaling.

Moving forward…
This is very frustrating and prevents me from being able to perform any worthwhile actions besides navigating around the model, albeit still not in an ideal fashion.

For now, on this Windows 10 device, I’ll have to revert to SU 2022 and won’t be able to use V-Ray, which is the reason I got SU Studio in the first place.

Any solution/workaround would be much appreciated. Otherwise, please log it as a bug.

What I’ve tried with no success:
Uninstalling and reinstalling Sketchup twice, with multiple computer reboots.
Updating my graphics card nvidia driver from 536.23 to 536.40.
Turning the trays off and on.
Turning the toolbars off and on.
Changing the graphics settings in Sketchup preferences.

I have previously had SU versions from 2019 through 2022 installed and working fine on the same machine and OS. And this viewport problem was not present in those SU versions.


You should check this thread

it’s about graphics card and scaling of windows.


The screenshot is a really weird resolution - 1920*1408

What resolution are you on and what kind of display is this?

The fact that your green axis don’t go to the edge of the modelling window makes me think that you are zoomed out very very far from the origin.

Was this model made using an original template that came with SketchUo or using a template of you own.

Try making a rectangle that is about 20 meters x 10 meters or 50 feet by 20 feet or whatever suits you. Then use Zoom Extend.

If it works correctly, it was like I described.

Adjust the zoom to your liking, delete the rectangle, clean your model as best as you can and save as a template.

Thank you! The post you linked to was helpful to point me in a new direction of testing, which was display scaling, which I admit I didn’t think of. I did note, in the post you linked, that someone (edit: happened to be @Elmtec-Adam) mentioned Sketchup supports up to 150% scaling, but unfortunately noy on my machine.

So, on my Windows 10 machine, I have two 4K/2160p screens.
When I had written the post, and the problem was presenting,
My main/primary screen is 31.5" and was set at 125% scaling.
My extended/secondary screen is 27" and was set at 100% scaling.

How I tested:
Scenario 1: 31.5" monitor set as “main/primary”. 27" monitor set as “extended/secondary”.
a) I set my 31.5" monitor display scaling to 100%, 125% and 150% scaling while it was set as my “main” display.
b). I also changed my 27" monitor display scaling to 100%, 125% and 150% scaling while my 31.5" monitor was set at each of the different scales, so I had 9 combinations.

  1. The problem existed only when the 31.5" monitor (i.e. the main display) was set to 125% scaling and up.
  2. It didn’t matter what scaling the 27" monitor was set at.
  3. I also did a couple of 200% tests – but not thoroughly because I never use 200% scaling anyway – and the problem still presented.
  4. Also, the higher the display scaling percentage above 100%, the worse the effect (i.e. the usable part of the viewport became smaller).
  5. I moved the Sketchup window between both displays for each scaling combination, there was no effect to the problem.

Scenario 2: 27" monitor set as “main/primary”. 31.5" monitor set as “extended/secondary”.
I did the same tests as Scenario 1… 9 combinations.
Results were exactly the same but for the 27" monitor, i.e. the problem only presented when the 27" monitor (i.e. the main display) was set to 125% scaling or higher, and the secondary monitor (31.5") did not affect the outcome regardless of its scaling percentage.

Note: I made all scaling changes while Sketchup was open, which I observed had no immediate effect on the problem (whether it presented or whether it didn’t present). I had to shutdown Sketchup and restart Sketchup for the effects to realise, depending on the scaling, which happens to align with the warning that Windows provides in the display settings, "Some apps won’t respond to scaling changes until you close and reopen them.

I also performed the same tests on my Windows 11 machine, which has three monitors, all at different resolutions (4K/2160p, 2K/1440p and FullHD/1080p). The problem never presented, regardless of scaling on any monitor.

My conclusion (so far):

  1. Both problems (scaled-down view and misaligned cursor) were in fact related.
  2. Sketchup 2023 (v23.0.419) does not properly support any display scaling on the main display above 100% on my Windows 10 machine. That said, I don’t know whether the factor is my Windows 10 (Build 19045) or some part of my machine’s physical configuration.
  3. This problem appears to be a bug, and having my main display set at 100% display scaling is a workaround, but not a solution. Thankfully, due to its larger screen size, I don’t have to squint to read text or find icons when using my 31.5" as my “main/primary” display at 100% scaling, and I can still set my smaller 27" monitor at a higher display scaling without issue.

Edit: Workaround:
Set your “main” monitor’s display scaling to 100%. All other secondary monitors can be set to any scaling without contributing to the problem.

My monitors are 4K resolution. My sketchup window was not maximised, but whether maximised or not, the result was the same. Changing the window size has no effect on the problem.

However, I did discover the problem. Please read my reply to @ateliernab , which has more information.


SU2023 supports scaling upto 200% , however it doesn’t support multiple resolutions/scale factors when multiple screens are in use. I think this will related to what is causing this

Thank you for your suggestion! Indeed, my first thought, as I had mentioned in my original post, was that it looks very similar to model clipping, and which appears to the same effect to which you’re referring - when zoomed too close to a relatively small object, or zoomed too far out from origin.

In my screenshots, you will notice the size of the "Heather’ person object is not tiny. You will also notice that all the axes are clipped, as well as the ground plane and the sky background. Although I didn’t take a screenshot, nav-panning around the viewport until any part of my model moved toward the top or right edge of the viewport would also result in the model being “clipped” at the region I previously mentioned.

To address your suggestions and comments:

  1. I was using an original template that came with Sketchup. However, the problem persisted regardless of whether I used a built-in template or custom template.
  2. I was not zoomed out very far from the origin, as evidenced by the size of the “Heather” person object, and the fact that I used a built-in template without zooming the view in/out before capturing the screenshots.
  3. I had tried opening models of various overall (dimensional) sizes, and being someone who frequently used zoom extents, this was the first thing I actually tried and it had no effect on the problem.

However, I did discover the problem. Please read my reply to @ateliernab , which has more information.

Still, I gladly welcome your suggestion! People like me (i.e. those who post about problems) often can’t find a solution or workaround without suggestions like yours to help us go through the process of elimination, and to give us insight we may not have thought of! Really appreciate it!

Actually, in my testing, Sketchup 2023 – specifically on my Windows 10 machine only – doesn’t support any display scaling above 100% on any monitor that is set as the “main” display - even on a single monitor (I disconnected my secondary monitor).

Only 100% scaling on the “main” monitor (whether it is the lone monitor, or part of a multiple monitor setup) appears to be free of the captioned problem. Display scaling on secondary monitor(s) have no effect on the problem, whether their scaling is the same or different to the main/primary monitor.

Regardless, thank you for your input!

Yeah, Clearly lots of anomalies with multiple monitors, there are lots of issues related to that.

I use a 4k display too - but only a single screen. I only have issues if I connect to my dock in the office and I have mismatches.

Hopefully later down the line it will be updated to be more robust

Actually, my point was that having multiple monitors wasn’t a cause of this problem, at least for this particular problem that I posted.

And in my testing, the problem existed even when there was only one monitor. And then, in a multiple monitor setup, the secondary monitors did not actually contribute to the problem.

Interestingly, I’ve always had multiple monitor setups since I first started using Sketchup (which admittedly was only recently in 2019) and this is the first issue that I’ve actually come across in all versions from 2019 to 2023 that was debilitating enough to prompt me to bother joining this forum and making a post, haha!

As I mentioned, I’m using a single 4K monitor also ( with 200% scaling) but via Windows 11 - so a different result from you. Lots of variables as you can see!

Is your main monitor connected directly to the GPU via HDMI/Displayport?
Some devices don’t play well with OpenGL

The UI framework that SketchUp uses changed in version 2023 - it should should enable more options for high DPI screens moving forward, but currently there are some weirdnesses and differences in behavior versus the 15+ years of versions prior.

Are you using a docking station?

A docking station, as in a monitor hub? No. Both monitors are plugged directly to the graphics card. No hubs, no cable adapters.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.