SketchUp 2022 - all keyboard shortcuts don't work in SU2022 when the Outliner is the active window - update: fixed in 22.0.354

This is a followup on an earlier topic SketchUp 2022: can't delete objects anymore from the Outliner without activating the viewport

It turns out all keyboard shortcuts don’t work anymore in SU2022 after selecting an object in the Outliner until the 3d viewport is activated. Steps to reproduce:

  1. create a few objects
  2. open the Outliner, select an object in the Outliner
  3. press a keyboard shortcut like ‘delete’ or ‘h’ for hide or ‘u’ for unhide, ‘g’ for grouping etc. → nothing happens (windows ‘ding’ sound)
  4. middle mouse click to rotate the 3dviewport
  5. redo step 3 → it works as intended

For people who use the Outliner all the time this is a big setback. In all previous versions of SU, it was a very fast mouse-keyboard combo to quickly hide/unhide objects. Only workaround for now is right-clicking the object in the outliner + selecting the command from the ‘window’ + mouse click again.

Really hoping this gets fixed somewhere in 2022…

2 Likes

Don’t you use the ‘eyecon’ in Outliner? No need to first select it.
With the new added searchbar, there where some things changed with the shortcuts, have you tried restoring them? (Btw. setting shortcuts for hiding doesn’t work on the Mac, either, not on version 2022 but also not on any earlier versions, but you can delete directly)

I rarely use the eye-icon because over the years I got used to selecting an object and then pressing a shortcut-key for whatever operation I would need next; grouping, un-grouping, hiding, un-hiding, deleting, re-grouping, etc etc

Not sure what you mean regarding the shortcuts+search bar. All shortcuts work as intended if the 3d viewport is slightly changed after selecting an object in the Outliner and then pressing a shortcut key. The 3d viewport just needs to get active again. Seems like shortcut keys are kept in some sort of ‘sleep’ mode in the Outliner in SU2022

1 Like

Ah, that was already the case on Mac, the activating the viewport, I mean. It seems as they are merging ‘worst of two worlds’ instead of ‘best of both’.
@Mark might have a clue?

Thanks for reporting this, @maxB. We will be evaluating this problem this week.

3 Likes

Thanks maxB for bringing to our attention.
I do see the issue you have brought up on both Windows and Mac. (bug SU-50560 internally)

Trent

3 Likes

@maxB

Just a thanks for bringing this issue up so quickly. In my workflow, both the Tag and Outliner panels are open all the time and I use them both. I was happy to see that the issue with clicking Tag visibility twice putting the tag name in edit mode had been fixed; then I see that Outliner no longer works the way it did, and my computer is constantly dinging at me that I’m doing something wrong.

I didn’t want to bring it up–I figured it was one of those ‘feature not bug’ things and I’d just have to get used to it. So, thanks again.

1 Like

Update 220225: SketchUp released a new update today and the issue is fixed.
Thanks a lot at the SketchUp team for so quickly fixing this - highly appreciated!

2 Likes