Sefaira in sketchup 2021 and revit 2022

Hello when i try to install the plugin of Sefaira in sketchup 2021 or Revit 2022 and error comes to me :
No supported version of Revit/Skethcup appears to be installed on your copure (17 or higher) it is required for use with this plugin. Please retry this installation once you have Revit/Skethcup installed.
i tried on my laptop with Revit 2018 and the same error occurs.

Hi @hakimZ,

I’ve heard the same issues show up with other users recently as well. Let me check with our development team to see what might be going on. I’ll reach back out as soon as I find out more.

Thank you, hope you can find a solution.

Hi @hakimZ

So the dev team mentions that,

"The only case for that message to appear, while SketchUp is installed, will be a custom path, the Sefaira installer does not support custom install paths for SketchUp, this however can be solved by using the plugin ruby archive.
You can download the archive from: Section 2A: Accessing Sefaira with the SketchUp Plugin – Sefaira Support in IT set up for Sefaira section or by using the following link:

  • extract the .rbz file from the .zip archive
  • open SketchUp extension manager
  • click install extension and select the .rbz file
  • the Sefaira plugin should appear under Extensions section (SketchUp application restart might be required if is not immediately visible)"

Can you give that a go and let me know what comes of it?

1 Like

thank you it worked perfectly with rbz file for sketchup, and it seems that the custom path was indeed the problem,
is there any way to counter that also in Revit 2022 ?

HI @hakimZ,

Unfortunately we do not have a workaround for the Sefaira for Revit plugin. The dev team tells me that Revit needs to be installed in its default path for the Sefaira plugin to work.

Ok, will try to re-install it in the default path, thank you for your time.

1 Like