Screen goes black on Mac

mac

#1

Hi there.

I’ve had this happen a few times since the last update. When I resume using the computer from sleep mode and select Sketchup from recent items in the finder menu to open it, the screen blacks out. There is no way to revert this. Everything is still running in the background and keyboard commands work but there is nothing on the screen. I have to press the power button to shutdown the machine and start again.
Does anyone have an idea why this is happening and how to prevent it?
Thanks


#2

Never experienced this on mac. When the screen goes blank I assume you cannot get a menu to pop at the top by hovering. How do you know the keyboard commands still work, volume and brightness are working I’m guessing. Are you using spaces? And was Sketchup in full screen mode last time it was used? This is not something I’ve heard of so I am suspicions of the OS causing the problem somehow.


#3

which SketchUp version?

macOS v10.12 is not supported by SketchUp v2016 (and older).


#4

It may sound strange, but it’s a known thing to have a Mac sleep when a magnet is near the laptop. Maybe Space Navigator has a magnet? An external speaker?


#5

a scheduled power saving is typically a desired behaviour… maybe the OpenGL stack of the video driver which doesn’t survive if power saving sends the graphics adaptor to sleep.

And restart your system… especially if not done since several weeks/month/years…


#6

"How do you know the keyboard commands still work, volume and brightness
are working I’m guessing."
Because I know keyboard commands. I can switch applications and do stuff
there, like I can switch to itunes (if it’s open) and start the music with
the spacebar etc. I assume everything else works but the screen. I can’t
tell if brightness is working, the screen is black!

"And was Sketchup in full screen mode last time it was used?"
No. It wasn’t. I hardly use it in full screen.


#7

17.2.2554


#8

I restart everyday at least once and have to restart when tis happens
anyway.


#9

Yes! It does sound strange.

No. There is no magnet. The sleeping is because of settings.


#10

Odd indeed, sound like a grafix card driver issue, but hard to explain. You come back from sleep and everything is working ok until you then select sketchup it will go blank? There is an option in energy saver control panel to enable/disable auto-grafix switching to swap between cards when needed, wonder if this would have any effect on the problem.


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.