Repeated crashing with Mac SketchUp 2021

And did you tried what is said in post 67:

Do you see any bugsplat windows when you try to reopen SketchUp? If you do, can you send one of them in?

Another place that I now check, after installing a new version of SketchUp on Mac, is the main HD library for any sketchup “parts” that should only exist in the User Library.

Mac usually offers you the choice of either installing in your ~Library or installing “for all users”. Even if you have the choice offered to you ( not always the case ) and you correctly install for only yourself, it is worth the 5 extra minutes to search the main library for any errant files.

same here. got the crash for the first and second times after trying to click the brick. After the second time it crashed every time I launched sketchup. I tried a lot of suggested fixes, but only colin’s terminal workaround has worked for me so far. I only started using sketchup after 2021.0.1 was even released.

Thank u! New to MacBook Pro and after installing the subscribed version of Sketchup Pro 2021, experienced exactly the same problem - when trying to colour my sketch, Sketchup crash and worse of all, can’t send the bug fix and no bug fix number was generated so I can’t get help from Sketchup.

Called Apple Support and they helped me to navigate based on your post to find the file to be deleted. Still didn’t work so tried your last option of duplicating the file. Now Sketchup works!

Thanks much for the tip!

I hope things are still ok for you, but the last bugsplat you sent in showed SketchUp was running from the disk image file. Can you make sure that you are running the copy of SketchUp that is in Applications, and if the disk image is still mounted, eject it so that you don’t accidentally open that copy.

Yes, that bugsplat was sent before I did a duplicated copy. After I did the duplicated copy, I have no more issues. I have also deleted the old copy in Applications and renamed the copy. Seems to work now. Will monitor and see!