Problem Downloading Extension Warehouse Items

In SketchUp (Make 2016) I click on Window>Extension Warehouse and receive the front-end interface panel; however, when I click on SignIn, I get the error screen below.

Can anyone tell me, please, what I’m doing wrong and/or what to look for to fix it?


I’ve noticed that if you sign in in the lower left corner of Sketchup before opening Extension Warehouse you are much more likely to actually be signed in. Signing in from the Extension Warehouse window within Sketchup almost never works.

Thank you for the response.

I use SketchUp Make V16. It doesn’t seem to have a place in the lower left corner to sign in as evidenced by the screenshot below. Is the sign in you speak of a feature of Pro, perhaps; or is there a screen format option that I should look into changing?

If this is what you are looking for, or referring to… it is the thing to click…Peace…

Thank you, sir!

I found the icon. Now what sign in do I use? My SketchUcation sign in or the SketchUp Forum sign in?

I tried both but neither worked. I then tried to use my google gmail address and PW with no success.


SketchUcation is an independent website company in Ireland.

Your SketchUp forum sign in (using Google ID) should work, or create a new Trimble ID account.

Thanks for the clarification, Dan.

I’ve tried my google ID but it doesn’t work. I then tried to set up a new google ID per the panel offered. I cannot seem to get it to take my password. I use a password generator tool that produces complicated passwords. I never use the same password anywhere. I read the information in the Trimble panel that says that the pw must be at least 8 characters and must include upper and lower case alpha, numerics, and special characters (from a limited set displayed). It does not mention a maximum length. Is the pw limited to a total of 8 characters?

The password I generated seems to meet all those requirements. It is 20 characters long.

I don’t know how to proceed. Any assistance you can give will be greatly appreciated.

I found the problem with my new password. The special characters set used by my pw generator and the one accepted by Trimble were different therefore I had an unacceptable character in the string.

I was able to set up a new Trimble ID and received the message that I would need to confirm using the email they would send me, but it hasn’t come after several hours. What’s more, my login in now locked (from all the attempts, I suspect) and I got the message to contact my site administrator but with no instructions how to do so.

I’m a bit confused about which things are Trimble and which are not. Is this forum run and supported by Trimble? (from context here I think it is a separate entity) As I understand it SketchUcation is a Trimble arena with separate ID and login, right? And the Extensions Warehouse is a Trimble login? And, of course, SketchUp is Trimble, too?

This forum is owned and operated by Trimble.

SketchUcation is a completely separate forum. While they are friends of SketchUp, Trimble is in no way involved with their operation.

1 Like

Yes separate everything. They are a separate company in Ireland.

Also, The SketchUp Sage website is a separate site run by Joy (@catamountain) but hosted on Google server (but has never had anything to do with Google otherwise, even when Google owned SketchUp.)

Yes, and they are all accessed under the domain. Just look up at the address bar of your browser.