Own RBZ extension creation - not seen by SU

Dear friends,
I am trying to create my own extension; i.e. just a menu option/or button that will run a .rb code (so that I won’t have to run it from the Ruby Code Editor all the time).
Reading the relevant article by Alex Schreyer and other posts here in the community, I understand that all I have to do is to zip my file and then rename to .rbz as the rbz is a renamed zip file. Providing of course that the structure of the folder is:

my_plugin.rbz (compressed file)
|-- my_plugin_loader.rb
|-- my_plugin (directory)
|-- my_plugin.rb

However, I try the traditional method to install an extension via the Window Menu, Preferences, Extentions and click in Install Extension and browse to my folder. There, I cannot see my rbz file. I can see other downloaded extensions but not the one I made.
Are there any zip settings that I omitted?
p.s. My SU version is 16.0.19912 64bit on Win10.

Many thanks.

At the point of browsing for the RBZ file SketchUp is not doing anything but looking for the file extension letters. Is it possible you transposed letters when you renamed the ZIP file? It’s not uncommon to see users refer to RBZ files as RZB in forum posts.

1 Like

How did you rename the file? In windows if you do not have file explorer set to show the extension then renaming the file extension does not as expected.

1 Like

A few pointers.
The RB file which makes the extension is put in the base level of the ZIP file.
A folder with the same name is also needed at this base level.
There should be nothing else in the ZIP at the base level - just one RB and the folder with the same name.
All other supporting RB files, images etc go in the folder, or even subfolders within that.

When you make the ZIP file you need your folder-options set to show all file-extensions.
Otherwise the ZIP file that is displayed as my_plugins is not renamed as you expect - when you rename that my_plugin + .rbz it becomes my_plugin.rbz.zip
so it’s not seen by SketchUp…
It needs to have the .RBZ on the very end !


Your version is out of date.

Latest version for Windows are:
16.1.1450 (Win 32-bit)
16.1.1449 (Win 64-bit)

See the official instructions at the SketchUp Extension Warehouse Developer Center:

1 Like

Dear friends,
Thank you for your input and apologies for not replying earlier. TIG’s final remark solved the problem. I had to configure the files explorer to show the file extentions and then rename it. I had been carried away that the rbz is actually a renamed zip file and just renamed it with a simple right click.
Problem is solved.
Thank you all.