Open floor plan model

Ok so I have created a 3D model of an apartment. I want to look down on it from above. I do not want it to have a ceiling. I want the sketch up light to only come thru doors and windows but not thru the top where the ceiling would be. Is there any way to make this work the way I want. Thank you in advance for any help on this problem.

You can create your ceiling, Group it, and put in on it’s own Layer. Then create a Scene. Scenes can be used to saved Layer Visibility, so in this case, you want a Scene where your ceiling Layer is off.

As for shadows, if you can leave the ceiling Layer visible, and use a Section Cut to cut through your ceiling.

Paint the ceiling with a Transparent PNG image.
A transparent PNG material is, of course, transparent. But it also casts a shadow.
There’s one between the dots.


In both it still shows the light coming thru the top of the model

The only way you can look down on the floor plan and keep the ceiling is to place the camera inside the model and just below the ceiling. That way only the light from the door and windows will be inside the model.

Make sure (Entity Info) what materials are on the face.
Here you can see how it works.
Same model, same shadow settings.

Transparent PNG Ceiling

No Ceiling

This is am example of what I am trying to achieve.

That is exactly what I am looking for. How do I go about making the transparent PNG ceiling? Thank you very much…

Transparent PNG Ceiling … White Background … Shadows On Ground are turned off

That is great!!! Thank you again…

The image is not visible in the browser because it’s transparent.
Place your cursor between the dots > Right click > Save Image As

Then import the transparent PNG into the model as a texture.
Importing 2D graphics as textures — SketchUp Help

SketchUp has only the Sun for light and no native photorealistic rendering capability as in your example.
Some like to turn the Sun off for renders and use global illumination, like the the one below.

Ok so I just did a render in SU Podium and the transparence did not hold. I am still getting the shadows.

Because it’s transparent, Podium sees it like windows and will still cast light through. And if you try Section Cut, section cut won’t stay active for Podium and you’ll just see your roof.
I think there’s a section cut plug-in that will keep the cut active, and perhaps not allow light through…

If you’re in a rush, perhaps make a very large rectangle way up high to block out the sun, but not wide enough to block the sun from reaching the windows, just a quick work-around for now until any of us figure out a better solution.

I will try that thank you.

Hi Rich,
As we know, the transparent PNG creates the desired effect within SU.
Nonetheless, I had the same problem as in your SU Podium example when I rendered with Kerkythea.
The remedy was to apply Kerkythea’s native thin glass material and set its properties to cast shadows.
The minor light leaks will disappear with some slight adjustments to render settings.

I will give that a shot. I did adjust the shadow settings getting a desired affect. Changed things like which objects display and/or received shadows. Still working on it some but here is an example of what I was able to get…

Some picky things: Your stove light is too strong, and gives a weird reflection on the floor. The Island is too reflective as you can see the chairs too clearly like a mirror.
You can increase the bumps for the carpet and the coffee table looks too flat

Just want to say thanks for this. I was searching for just this solution and it has worked a treat!