Object Volume - SketchUp Web

I’m using the free version of SketchUp Web. I’m trying to determine the volume of an object. Thinking that the issue was that I didn’t have a “perfect object”, I tried creating a cube (rectangle → extrude) and check its volume, but got nothing.

Can anyone tell me the volume (in liters) of the object in the attached file? I’m trying to figure out how much water my boat (design) will displace. This object is from the DWL (“designed water line”) down.

Inboard Boat 3 Displacement.skp (138.3 KB)

It will sink, there is a gap:

Try modeling half and then mirror it.
It needs to be a solid before getting any volume

In order to get a volume you need to have created a solid group or component. Yours isn’t. There are some hidden edges, holes, like @MikeWayzovski shows, and other issues.

Sort them out and you’ll get a volume in Entity Info.

Thanks, I’ll go try to fix it. Why, though, didn’t my cube provide a volume?

Did you create a component or group of the cube or was it all just loose geometry? With it being a solid component or group a volume will be displayed.
Screenshot - 10_20_2022 , 2_56_48 PM

I did. I drew a rectangle, extruded it to make a cubic shape, selected the entire thing, hit Ctrl-G and gave it a name, then tried to view its entity info. Nothing. So, banging out this message I tried again and it worked. So now it’s down to fixing my model. I’ve pored over it and think I’ve fixed everything, even tunneling through it with a section plane, but I’ve clearly missed something somewhere. I suppose I’ll keep at it. Thank you for your support.