Not sure which computer / graphics card I need for best SketchUp results

Hi all,
I’m a student and recently bought a new computer - MacBook Pro with 32 GB memory and an AMD Radeon Pro 5300M 4 GB Intel UHD Graphics card. I’ve been having some issues when building my models where SketchUp Pro completely shuts down or I get the spinny wheel for far too long. I prefer to use a Mac vs. PC but I’m wondering if I should have gotten a different graphics card. Does anyone have any advice or graphics recommendations for optimal results? Thank you so much!

What’s the Mhz on that model? Sounds like it should work fine and you may be coming up against the general limitations of SketchUp. Shutting down completely doesn’t seem right. How big are the files? Have you tried turning off graphics switching (using only the higher end card)?

Of course there are ways to work that help, starting with turning off shadows when you don’t need them.

The MHz is DDR4. Some files are around 150 MB and over. Do you think that’s causing it to happen?

I haven’t tried turning off shadows etc., but I will. Thank you!

Looks like your macbook does not use the radeon gpu.
Go to System Preferences > Energy Saver
Choose your own path.
DISABLE automatic graphics switching to basically force the 5300M to be used all the time.
ENABLE automatic graphics switching for the OS to handle swapping between Intel and 5300M as needed. This yields the best battery life.

All of the cards for your Mac are AMD and the performance difference isn’t that big to make a difference. Chances are you are modeling something that is too complex for your powerful machine. I also have a MBP and don’t have any slowdown issues so I’m pretty confident you’re modeling in a way that would make any machine struggle.

AFAIK your ultracool new Macbook should be able to handle quite challenging SketchUp models. I don’t use a Mac so my suggestions are sort of general.

  • Are you using plugins? - some of them might be causing the issues
  • Also, using Autosave might be interfering with your work, especially if your models are large
  • You shouldn’t be saving (or autosaving!)your models directly to folders “in the cloud” or folders that are automatically synced with the cloud.

And follow tips for modelling to reduce the load on your machine while you are working - for example:

  • turn off Profile edges, Endpoints and Jitter in the Styles/Edit window, and/or choose high performance styles while modelling
  • model in Monochrome (View/Face style/Monochrome) or have it on a toolbar to toggle quickly between modelling and viewing with materials and textures
  • turn off unneeded Tags/Layers to hide objects you don’t need to see while modelling
  • turn off Shadows
  • don’t use models from 3D Warehouse without examining each first in a separate model. Many, perhaps even most, are VASTLY over detailed to use as part of other models. Redraw or simplify radically before using them
  • set up a scene or scenes with simple styles to model in, and set up others to view the model in full colour and detail.
1 Like

I don’t have projects much over 80 MB at the moment, and virtually no lag in SketchUp, so maybe I can’t say what happens at 150MB. Also it can have to do with the shear number of polygons and size of textures, beyond just the file size. Since you haven’t tried turning off shadows… I’d look at the fast modeling advice here as well as checking into how the graphics cards are being used.

Another thing. You don’t have to have all objects visible while you work, use layers to hide groups and components that aren’t being modeled. Plants, furniture, cars, people don’t need to be seen at all except in final output scenes.

1 Like

On a Mac there is no other graphics card you can get.

You can use a egpu via thunderbolt for more 3d performance.
Not available for M1-Processor yet.

But in this case here, the mac has 2 gpu - a 3d performance radeon and a intel graphics.
Maybe the Mac does not use the radeon-gpu when sketchup is running.

1 Like

I have recently upgraded my iMac and it uses an almost identical video card as yours. I found that the new setup really makes Sketchup fly (but not Layout which is still stubbornly sluggish).

I never have models anywhere near the size of yours so I would suspect file size as the culprit. I don’t know how new you are to Sketchup but I guess you may be as a student. One classic newbie error is to think you can save time by importing ready made models form the 3D Warehouse. You can if you know what you are doing, but uploaded models can have all sorts of issues, bloating with excessive detail being no. 1. That will quickly overwhelm a drawing and make it difficult to work on. But if you have to do it, others here have outlined some workarounds that will help.

1 Like

You’ve gotten some good tips about things to avoid for best performance.

But I’m surprised that nobody asked you to report the thing most likely to cause severe slowdowns: open Model Info->statistics panel and tell us what you see as the edge and face counts. Counts in the millions will surely cause slowdowns. That matters far more than sheer file size. Unless you have clicked the “purge” button on that panel, the file size could result from unused components and materials that don’t affect performance except during save (see also regarding autosave below).

Second, I wish people who don’t use Macs wouldn’t make ill-informed suggestions. Every Mac i’ve owned reliably detects that SketchUp needs the 3D graphics capabilities and switches to that graphics when automatic graphics switching is on. If in doubt, you can open SketchUp->Preferences->OpenGL and click the Graphic Card Details button. It should show that SketchUp is using the Radeon graphics, not the Intel graphics.

Finally, if you have autosave turned on, try turning it off in SketchUp->Preferences->General. If your model is complex, autosave will cause periodic freezes because the save takes time, and there are reports of crashes if extensions happen to trigger in the background while an autosave is in progress. I don’t recall if specific extensions have been proved to be the cause (the crash reports show an extension was running but don’t provide enough info to tell which one, so narrowing it down is tedious). But turning off autosave avoids both the mystery stalls and those crashes.

If you can provide a sample .skp file that causes issues for you (you will need to load it to a file sharing site and provide a link here, your models are too large to upload directly to the forum), others can investigate whether they also see slowdowns and provide more specific information about any causes they detect.

2 Likes

I use a MacBook Pro 16" Core i7 2,6 and the os decide witch gpu is used - when i run on battery sketchup uses the integrated gpu…

Interesting. I have a 16" MBP also, and I have never had macOS choose the integrated gpu for SketchUp when on battery, even after running for a while and checking About This Mac to see that only the integrated graphics are reported there. I wonder what is causing our different behaviors?

1 Like

True but what I meant was there is NO Nvidia option, what so ever. Should have made that point clear.

Sketchup make 2017 maybe, sketchup 2021 runs with dedicated gpu on battery as default.
Anyway, back to topic :slightly_smiling_face:

True.

Apple and Nvidia had a falling out some years ago (rumored to be IP and licensing issues over Apple writing their own drivers). Apple switched entirely to AMD Radeon and Intel integrated graphics at that time.

However, I don’t think Nvidia vs Radeon has much impact for SketchUp itself. Certainly not enough to be the main factor causing your issues or for decision of which computer to get. SketchUp does not place a very high load on the GPU compared to games.

Some renderers (notably V-Ray) require Nvidia CUDA to do hardware acceleration. On a modern Mac with only Radeon or Intel graphics, V-Ray will only do CPU-based rendering, which is much slower. If you plan to do a lot of complex renderings and don’t have time to wait for the CPU renders, a Windows box with Nvidia would be a better choice.

I have no experience with external GPU (e-gpu) boxes, so I can’t offer any advice there, other than it means taking on additional expense and complexity.

1 Like

I’ve used both and I’ll not switch back to ATI/AMD unless something BIG happens. Now I’d take an AMD cpu ANY day over Intel but NOT their graphics.

1 Like

Agreed. Frustrating seeing comments about graphics cards and settings. These aren’t issues on a Mac like they have the possibility of being on a windows pc. If sketchup is too slow on apples most expensive laptop, it’s most likely a modeling issu, since we can rule out hardware specs at the outset.

LOL, posting from my 1st gen Mac Pro desktop. Also own an iPad Pro.