Nearmap aerial imagery is now available in SketchUp’s Add Location!

Quality compared to Google much better for me. Might just be location?


I don’t know what you mean by examples. I type in an address, and the cross hairs are never on the right property. Not even close. It can be 2-20 houses away from the correct property in any direction. It never gets it right and this coincided with the latest update to Add Location. There is no rhyme or reason to the direction or distance from the true location.

I was curious. I’ve typed in about a dozen different addresses this morning and the cross hairs are dead on accurately placed. Can you share some addresses that give you the problem you indicate?

Sure. Here are 5 random recent searches I made. I screenshot where the crosshairs show up and put a red X on the correct property. Before the update I never had a problem with Add Location finding the correct address.

20070 Petrucka Cir, Lehigh Acres, FL 33936
1425 N Larkwood Sq, Fort Myers, FL 33919
3924 Upolo Lane, Naples, FL 34119
1826 SW 25th Ter, Cape Coral, FL 33914
13702 Pine Villa Lane, Fort Myers, FL 33912

I wonder if what is happening is that the map is organized by fixed-location tiles and the geolocation UI is finding a tile that contains your search address, but which isn’t necessarily centered on your search address?

IMO, Trimble should have just bought Placemaker and integrated it (and improved upon it to reduce the number of steps needed to import imagery). This latest Add Location update is a step backward in some ways. We’re headed in the wrong direction in terms of both cost and simplicity, two areas where Sketchup used to shine.

That does not appear to be the case. Here is what I see for 20070 Petrucka Cir, Lehigh Acres, FL 33936 when I select a provider.

I was a beta tester for Placemaker 1.0, but haven’t used it for a while. If you wouldn’t mind telling me the steps to do a fair comparison? Here are two of your example addresses, the red star is the center of where Placemaker gave me, and the green star is the real house. For the second example I had zoomed out one level, and still had to put the green star outside of the image area.

I am assuming that I did something incorrectly.

I’m talking about the Add Location window in Sketchup. This problem has nothing to do with Placemaker.

I was responding to the part where you suggested that Trimble should have bought Placemaker. That made me think you were saying that Add Location gets the address wrong, but that Placemaker gets it right. If Placemaker did get it right, that means there’s something that should be fixed in SketchUp. If Placemaker also gets it wrong, then the data needs fixing.

This is definitely a Sketchup problem, not Placemaker. Placemaker correctly imports imagery for the selected surface once Add Location has been completed. The problem is that Add Location does not pinpoint the right location when searching for an address in my area (Florida).

It just hit me based on two member comments that you can use Placemaker to geo-locate and bypass the Add Location feature in Sketchup altogether. That wasn’t clear to me until now.

Sadly, that Placemaker feature is not working for me, either! Here is what I get - just a spinning icon.

What version of PlaceMaker? ([menu]Window->Extension Manager
should be 3.06
Does it work when you disable ‘Large Area’ ?

Yes, version 3.0.6, and no it does not work when Large Area is disabled – same result.

Mac Mojave earlier today. Max Catalina now. Same result.

I can zoom in and import an area. Search just doesn’t work.

Are you pasting? It works for me if I start typing

Google prohibiting use of their images in Sketchup would be humorous if true, since they bought the software from At Last and sold it for quite a while.

It is true. That’s the problem.

I hit that problem when trying some of your example addresses. For the ones that worked it was still not obvious how to use the search. When you type or paste, all being well a drop down menu appears. You have to click on an entry in that list, pressing Return will not select the first one automatically.

As per my screenshots though, when you do succeed in getting somewhere to import, the address accuracy seems to be worse than the Add Location feature.

Doesn’t work either way.

Ah, I see how the Placemaker location search works (or doesn’t work). Not being able to paste is sub-optimal. And it doesn’t even find some addresses when I type manually.

Moreover, as you said, the location accuracy is even worse with Placemaker. It’s essentially unusable.

Something is wrong with the geocoding for both Sketchup Add Location and Placemaker Geo-Location. At this point I wish I could go back to the old Add Location and then import imagery with Placemaker the way I was doing it before, even though that’s not an optimal workflow.