Mesh kit configuration for gmsh

mesh

#1

I follow this tutorial:


At 2:22 there is an option Quick Mesh Options. I found that when I do the same, there is no mesh generated. I installed gmesh into “Gmesh path:” C:\Program Files\gmsh-3.0.6-Windows32 … I tried to configure Mesh kit. I tried both the directory and the gmsh.exe file path, using “Active Mesher:” gmsh. Unfortunately no one of the path works to me. The mesh was no generated. I can run the program separately but I cannot to generate the mesh in SU 2016. Any solution for this?

#2

Looks I have found some post of the author of the extension which could make things more clear.

Peter V
2 years ago

Hi Andrew,

Thanks for checking out the extension!

So, a couple possibilities spring to mind:

  1. Make sure the gmsh path in Meshkit (the right-most button) is set to wherever you have gmsh installed. It should look something like this for Mac: /Applications/Gmsh.app/Contents/MacOS/gmsh or this for Windows: C:\Users\Andrew\Desktop\gmsh.exe

  2. Make sure the object that you want to mesh is in a Group (not a Component) and that it is selected when you click “QuickMesh”

If these don’t solve the issue, just open the ruby console, try again, and copy the output to a text file. Then, if you could share a Dropbox (or equivalent) folder with the text output and the sketchup model - I’ll take a look.

Thanks!


#3

What I found so far, when I select the group and I click on Quick mesh, there is send this text to ruby console:

Region: 1 has subregions: false
Region: 1 has subvolumes: false
Region: 1 has adjacent: false
Region 1 has no subregions or subvoumes.

However I do not know how to create subregions or subvolumes, if this is what is needed.


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.