Making Cutouts Using Intersect Function

I’m drawing a replica of an EMD 567 Locomotive Engine which is going to end up being 3D Resin printed. The front accessory cover is causing me fits. I rounded the edges using Fredo Round Corner, and I put objects on a path using the Copy on Path extension on a path made solid by the Weld extension. I’ve done this before in fluting a column by embedding a cylindrical shape into the sides of the pos, intersecting the faces and removing the parts of the cylinders leaving the flute carved into the surface. I’ve tried the same thing here, but the results are all over the place. Some are leaving the cylinder wall behind giving me the cutout that I want. Others have the wall removed showing the hollow interior of the cover which would be unprintable in that form. The cylinders are a component that was copied around the path. I did notice that some of the cylinders had their faces reversed. When I pushed the cylinder in, some of them pushed outward, backwards from the one I pushed.

567 Accessory Cover.skp (475.7 KB)

When you did intersect faces, did you place the objects inside the group of the cover? If you did it from outside the group, that may be why you didn’t get faces where you want them. One position looks like two objects were on top of each other. One object clearly missed the edge. If you include the steps or model BEFORE the operation, one might be able to see more. In this example all the results look similar, though it’s impossible to say why there are extra edges here and there.

I probably posted prematurely. While waiting for your response (which was right on) I went on Sketchufication’s forum and found someone asking the same question. I had to explode the components and then the intersect worked as it should giving me the correct internal faces. Thanks!


I suggest you to rotate the path and then apply copy along path… You know, it is important to adjust the component’s axes point, in my example it is on the center of the bottom circle… After that you can rotate all to the first position…

1 Like

Good point. I always forget about the component axes. I think I’m going to scrap the whole thing since I got all of them intersected correctly except one. And that one is a mess. I’m trying to heal the surface so I can start over it’s just getting worse. I’ll use your suggestions on the new version. I saw that the components have to be exploded to work properly on the intersection.

You can use the solid tools also… After placing the components, make them all one group and explode them from inside of the group, so solid tools will know it is a solid group even there is a lot of parts inside of the group…

I’m using Make so Solid Tools is not an option. Perhaps, later this year, I might be able to go pro. Meanwhile, I redid the job using the suggestions. By exploding everything and then doing the intersect, the carve out went beautifully. It was tedious since i had to remove the unwanted surfaces one at a time.

I then grouped it. I’m now going to drop some bolt heads into the grooves.

Again, thanks for the help.

1 Like

You can fix the reversed faces–if you soften the shape (enough to join the rounded surface), select all, DE-select the two outer surfaces, and pick “reverse faces”.