Layout PDF unrecognised by Corel Draw 6


#1

I have never been able to successfully import a Layout exported ‘text into PDF’ into CorelDraw 7 (or 6). I have used workarounds for the last few years, but have started thinking that with a licensed copy I should be able to do it without issues (unless there is a known bug).

The end result of my intention is to design models in SketchUp for laser cutting/engraving. I usually only cut and therefore export the PDF out of Layout as a vector, import into CorelDraw, tweak curves into single segments, colour change for cutting and then cut on the laser. If I ever wanted to engrave text I design it in CorelDraw direct over the imported design.

I am currently running a project where it would be easier to format the text in layout and import that into Corel for subsequent engraving. However, every time I try to import a PDF file into Corel containing text I get a “File is corrupted” message and the file is not imported. If I delete all the text, it imports ok. Again with this project I encountered this issue and tried for hours to tweak formats, play with the PDF file using other apps but import still failed. As a last resort I created simply a two word text “Test Text” in times roman font and exported to a one page PDF file which I tried to import into Corel. This simple operation failed. The same text using Microsoft word or Nuance Power PDF worked without issues. I can only conclude it is something to do with how Layout is formatting the PDF.

Alex


#2

Just a correction to the topic. “Layout PDF TEXT” with the emphasis on TEXT.


#3

Hi,

I’m not current’y on a Windows machine, so I don’t remember exactly how Layout handled it’s pdf exports. But it seems to me that you might be able to go about things in a different fashion.

When I was on Windows I had a fully running version of Acrobat Professional, and I always used the Printer Dialog menu to access the Acrobat Rendering Engine / PDF Distiller options which were available.

The ‘Nuance Power PDF’ software which you mention might also provide you with a method for generating pdf files from the Printer Dialog menu. If so then try that out and see what happens… The default settings might be all you need for success. and if not then look into any preference settings that you can get ahold of and see what the options are.

I think you should be looking towards anything that’s going to allow you to adjust the settings for ‘Embedding Fonts’, or ‘PostScript’ related terms… perhaps 'PostScript Fonts’, or ‘PostScript Outlines’, something along those lines.

I’m hoping that you just happen to have a setting at play which isn’t working as it should given the font, or font type, that your trying to use… Which I’m not sure what that is since you don’t mention it.

You probably don’t have a lot of choices in what you can adjust regarding the pdf settings. So see what you can locate, and keep an eye out on the buzz words I mentioned above.


PDF is essentially a printing technology.

IF the Nuance PDF Program you have actually includes a pdf distiller engine, then you should be able to access that via the printer dialog menu. and you’ll need to look for it amongst the listed printers, and of course choose it as your printer option. (instead of your default printer which is already highlighted and selected).

It’s initially confusing because it looks as if you’re making a printout, but what you’re really doing is printing to pdf format. …and at some point in the process you’ll see an option pop up for naming and saving your file… similar, if not identical to the Export, and Save menus.


Not a criticism here… but in terms of pdf issues think FONT before you think text. Chances are, the problem has something to do with the font type, and how it’s embedded, or how the postscript outlines are being converted.

Another test would be to use a different font to see what happens from within Layout.

Also substitutions can come into play… Word might have swapped in another font, as a substitute of what you actually chose, and that could have made the difference in terms of why it can do something which Layout couldn’t.

Don’t really know, but just to toss out ideas…?


#4

Thanks Jim, I will go and check out some of the suggestions. I only mentioned ‘Nuance Power PDF’ software because it was the only vehicle I use to generate PDF text. I believe you are correct in font translation as Corel pops up a “Font substitution for missing fonts” panel. I just would have thought that a plain Times New Roman out of Layout would easily be recognised by other applications (Corel). I have toyed around with different fonts and settings in Layout, however, only “toyed”. Will get more serious and put in a greater concerted effort.
Thanks again, Alex


#5

I had a look around and could not find anything off significance in Layout (not sure where I look for ‘Embedding fonts…’ etc. these terms are not familiar to my basic knowledge). All I have ascertained is that when I create ‘Arial, normal’ 20pt. text in layout and export that one page to a PDF, when I read that file (in Nuance Power PDF) the font is recognised as ‘ArialMT-Identity-H’. Also when I try to import the page into Corel it also identifies it as missing font “ArialMT-Identity-H-Normal” and when it tries to translate it I get a “The File is corrupted” message and import stops. I have tried to change the font in Power PDF to plain Arial and when I try to import it into Corel, I don’t get a missing font message just the “The File is corrupted” message. No matter how I try to modify the file it is corrupted to Corel. If I create a new file in Power PDF with the same text and font I used in Layout, it imports ok into Corel.
This makes me think it’s something Layout does to the font. This probably could be easily fixed by anyone that had Layout and access/uses Corel Draw.

Alex


#6

Can you post up both of your files—the pdf you made and also the unconverted layout file.

I’d like to see how the pdf reads on my computer, and also see what happens when i try to generate a pdf from your layout file.

I’m running everything off of a macbook pro, and it has a slightly different method of generating pdf files.

Others around here will undoubtedly have a windows computer which has different pdf software installed hopefully someone has adobe acrobat which has a full set of options available.



The SketchUp team has a Layout expert who chimes in frequently. His name is Marc, and based on his avatar I think he spends a lot of time ontop of a snowy mountain. :smile: At some point he’ll get down here again, and we’ll get some expert advice on how layout handles its pdf exports.

In preparation for other folks coming in to help troubleshoot… You might want to comment on what your computer specs are. At least the OS in use, and what version of SketchUp / Layout your working off of.


#7

Attached are the layout and PDF file. In the layout file, page 1 is what I wanted to import into Corel (and failed). So I split the text and diagram into pages 2 and 3 respectively. The diagram imported (page 3) but the text (page 2) failed. So I created page 4 which is all that I exported into the attached PDF file. That failed to import into CorelHex Nut Template.layout (85.8 KB)


#8

Only 1 attachment per post, so here is the PDF.Hex Nut Template.pdf (15.5 KB)


#9

Corel error screen dumps attached (2 files in 1) as I can only post 1 uplo

ad at a time.


#10

Your pdf opens with no problem on my machine…


#11

Here’s the pdf I generated from your layout file…
Hex Nut Template.pdf (45.2 KB)

which look like this…

You’re layout doc has four pages to it. page 1 is seen above.

after that it looks like there is a layer separation, or something, in that page 2 shows the dimensions, and annotation; page 3 shows only the hex nut drawings; and page 4 shows that ‘Test test’ which I posted above…


#12

and of course page 4 is the same as the Test Text as seen above


#13

Alright, this all goes along with what I was able to see, and post screen shots about above.

Are you able to change the current status of the ‘Use the PANOSE suggested match’ setting, and choose the one below… 'Substitute font with: [ …]

That should open up your Font folder where you can choose some other font manually,



#14

PANOSE is a type of classification system, which attempts to find a close substitution for a missing font. I don’t use this very much, so I’m not sure what effect it has on the issue at hand. but I don’t suspect it’s very much if anything at all.

Corel is not finding the font which was used even though it is there.

A couple of reasons might explain why…

1)- is that the FontType between what Layout used, and what Corel is looking for are different.

2)- It’s not locating the font by it’s unique individual name. (…or, possibly not searching the correct folder ??)

3)- as an outside guess (which probably isn’t the case here) confusions of this sort can happen when there are a lot of installed fonts to choose from. By a lot I mean several hundred, and if you had than many of them you’d probably already know about the nature of this problem. so back to points 1, and 2 for now.


Below are some comments which I was writing earlier in the night. I held off on them because I didn’t want to jump too far ahead too early, and didn’t want to add in any confusion. At this point they go to support the ideas from points 1, and 2, and hopefully paint a clear picture of how thing can get messed up all these different Font options.



The Font names that you mention… ‘ArialMT-Identity-H’… are the ‘Real’ names of the font.

And are describing a particular variation which might differ by weight (stroke thickness), or angle, or some other unique characteristic which distinguishes it from its larger group affiliation to the Font-Family called ‘Arial’. (other varients exist as well… bold, italic, Ariel Narrow bold, Ariel Narrow italics and so on).

A professional quality font-family might have a dozen or more unique variations to choose from. The fonts that get included into the OS will usually be a small set of options, and they’re not always of a high quality. Design programs such a Illustrator, or inDesign, or possibly even Corel will often install a wider sampling of professional grade fonts and this stis very well with the graphic designers, and typographers who use this software. They like the extra options and slightly better quality where it exists.


The other part of this is that there are also different Font Types. and you’re not currently being able to see what those are.

In general you’ll see two main options…

  1. TrueType Fonts .ttf
  2. OpenType Fonts .otf

…but there a few others as well, mostly older font formats that don’t often get included with the modern OS’s, or software packages. You’d more likely run across them If you’ve downloaded a lot of fonts from the internet, especially the free offerings.


Now while it shouldn’t work like this, and I can’t explain why sometime it does… If Layout is specifying a font of one variety, and of a specific type, BUT Corel is expecting to see something slightly different (in either type or variety) that could be cause enough for not opening a file, or flagging it as a corrupted one.

If the file was corrupted, I wouldn’t expect to open on my end. But since I CAN view it, that corruption warning seems questionable. ??


#15

Hi Jim, I never had an issue creating PDF files from Layout or opening it in Acrobat or other PDF readers. MY issue was that if the PDF created by Layout had text, it would not import into Corel. Of the 4 pages PDF I created in Layout pages 1, 2 and 4 would not import into Corel while 3 (without text) was OK. My output seemed the same as the PDF you sent. Having said that, I could import your PDF, all pages (including text) into Corel. I tried the same on my other Win 7 PC with the same results (I can import your PDF but not the one I created). It seems that it is either a Windows/Layout issue or Layout/my_environment (maybe Power PDF may get it’s hooks into PDF files).

To your other question, of the Corel prompt of ‘Use the PANOSE…’ I have tried all the available options without joy. However, as I can import your PDF it is a case of trying to find out why my Layout will not generate a readable PDF.

My first attempt will be to uninstall Power PDF on a unimportant computer/laptop that I can recreate this issue and then try to activate layout on it and see if that fixes my issue, otherwise if anyone else running Windows could generate the PDF file (like you did) and send it to me so that way I can rule out a Windows/Layout/Corel issue.


#16

That’s good news, which suggests that the fonts not being properly embedded in your workflow.

Installing and trying a different pdf software is a good idea.


#17

Jim, I started up Sketchup on a fairly bare bones laptop running Win7 Home edition. No PDF software installed other than Adobe Acrobat std. (free version), though I may have copied fonts across from my old Win 7 PC some years ago. The same thing happened… could read your PDF but not mine.

I haven’t downloaded more than about 1 dozen special fonts from the Internet on my current PC and what I have are what is installed with the various licensed applications I have purchased in the past (I tend to steer clear of freebies). I take on board that this is probably a font issue and probably point 1 in your explanation (BTW. thanks, thorough and brilliant). However my concern is that Page 4 off my Layout document uses the standard available pull down font selection (ARIAL-normal) which should be the same as I used in Power PDF pull down (which did import into Corel).

Just an aside, Corel did prompt for a substitute for the fonts from your PDF (similar to those in the screen dump I uploaded previously), however, the substitutions worked, while my file(s), from layout with text, were reported as corrupt. With your PDF, I could substitute any other font in the pop up screen with success.

Unfortunately I don’t know anyone with Win8 that has a copy of Layout to see if it could possibly be a Windows/Layout issue. If not, any suggestions of where to from here as I have no idea of how to debug such an issue? I have just spent some time trying various common fonts (Arial, Courier New, Times New Roman) in Layout with the same corruption issue, so I am somewhat leading to it being a Layout output issue, however, I will not rule out any other application conflicts but it seems strange as all font selections for different applications seem come out of the same “pool”.


#18

Hi Jim, Interesting comparison. The screen dump on the left is Corel prompt for you PDF while on the right is mine. Note the difference, yours have a 5 capital character prefix in front of the font. Also another interesting thing is that Corel prompts for importing text as (see the dumps stitched below the abovementioned images) either text or curves. The top 2 screen dumps are for importing both yours and my file as text. However, when I import mine as curves, there is a string off 5 capital characters in front of the font (as per the last picture bottom right).


#19

Your original PDF also opens correctly in Adobe Illustrator CS5. One thing also comes to mind: is CorelDraw 6 expecting the PDF to be in an older PDF format?

Anssi


#20

That’s a Good point Anssi. If we’re talking about CorelDraw 6, then that’s very old software. originally released in August 1995.

I sort of hope this is the case as it brings in legacy issues that can explain an otherwise tricky problem.

I think that Alex might be using CorelDraw X6 however, since that is what’s shown on the one screen capture from the file corruption message above. plus the window shell look like a modern design.

I was never sure about which version of CorelDraw is in use here, and it would be nice to confirm that it is X6, if that’s the case.

If it’s NOT CorelDraw X6, then the age difference between pdf formats, and even fonts, could likely be the problem.